No puedo instalar PfSense desde live CD



  • Hola a tod@s,

    estoy intentando hacer una instalación desde el live CD 2.1 Release, sale el menú elijo la opción 1 y tras realizar todo el chequeo de dispositivos y demás se queda en:

    Tryning to mount root from cd9660:/dev/iso9660/pfSense
    ROOT MOUNT ERROR:
    if you have invalid mount options, reboot, and first try the following from
    the loader prompt:

    set vfs.root.mountfrom.options=rw

    and then remove invalid mount options from /etc/fstab.

    loader variables:
    vfs.root.mountfrom=cd9660:/dev/iso9660/pfSense
    vfs.root.mountfrom.options=ro

    Manual root filesystem specification:
      <fstype>:device>  Mount <device>using filesystem <fstype>eg. ufs:/dev/da0s1a
                                        eg. cd9660:/dev/acd0
                                        This is equivalent to: mount -t cd9660 /dev/acd0 /

    ?                            List valid disk boot devices
      <empty line="">          Abort manual input

    mountroot>

    ¿Alguien me puede decir que tengo que hacer para que salga el menú de la opción 99 y poder instalar el pfsense?.

    gracias</empty></fstype></device></fstype>



  • Disculpa la pregunta, el disco esta bueno? prueba arrancar en live a ver si se puede, chequea el disco para ver, sino intenta quemar otro! comprueba que el disco duro este bueno tambien, saludos!



  • Estás usando un CD-Rom USB? prueba usar la opción cuando arranca de usar unidades USB, creo que era la 4, o trata de usar la opción 7 que creo que es la que ejecuta con Debug y avisas.

    Saludos.



  • Gracias por las ideas, el cd está bien, aparte he probado con otros 2 uno de ellos con una versión anterior. El disco duro he probado que no tenga ningún problema. No estoy usando un cd-rom usb. Lo pongo difícil eh?

    He estado trasteando y he cambiado el cable IDE. He dejado uno en una controladora (la primera), para el disco duro. Y otro ide en segunda controladora para el CD-rom. También he formateado a bajo nivel el disco duro.

    A partir de este nuevo escenario la situación a cambiado, ya no se queda en ese dichoso mensaje de "ROOT MOUNT ERROR:"
    pero tengo otro problema al intentar instalar con la opción 99 monta el modo gráfico y demás, pero sale el siguiente mensaje:

    Execution of the command

    /sbind/fdisk -v -f /tmp/format.fdisk ad0

    FAILED with a teturn code of 1

    y al ver el log detrás de los datos de los dispositivos sale lo siguiente:

    ´-<<< Executing /sbin/fdisk -v -v /tmp/format.fdisk ad0´ : *******Working on device /dev/ad0 ******* : fdisk: invalid fdisk partition table found : fdisk: WARNING line 1: number of cylinders (120155) may be: out-of-range : (must be within 1-1024 for nomeal BIOS operation, unless the entire disk : is dedicated to FreeBSD) : fdisk: ERROR line 1: number of sectors must be within (1-63)->>> Exit status: 1

    Da la impresión de que no puede crear las particiones en el disco duro. Es un disco de 250 gigas sin nada. Le tengo que crear algún tipo de partición? o el software ya se encarga de hacerlas?,

    saludos y gracias!!!



  • ad0 en *nix se refiera a un Floppy Disk (Viejos recuerdos de eso) no entiendo porqué trata de escribir allí.

    El BIOS te reconoce el HD? como Master?

    Intenta con la opción DEBUG que te indiqué antes, y por el amor a Cristo, no uses entorno gráfico  :D

    Saludos.


Log in to reply