Recover from HW reset



  • Hi Stephen i also tried downloading hyperterminal, set baud to 9600 and 38400 still same, nothing happens.


  • Netgate Administrator

    Hmm, ok. Well I would definitely try to get it working in windows, using a vm inside vmware introduces way too many new possible problems. Plenty of others have made this work.
    What com port are you choosing in putty or hyperterminal? If your usb-serial adapter is correctly installed I expect it to appear as, say, com5.

    Steve



  • well its random, sometimes com 6, 7, 8 or 9.  It really puzzle me why its still not working, even if i already the stuffs needed to run this, specially the null modem cable


  • Netgate Administrator

    Do you have anything else you can use to test the serial connection?
    In newer versions of windows you need to run putty as admin.
    Rather than running backtrack as a vm you could try running it as a live cd.

    You should also be able to just re-write a new image to the cf card. There are default settings for the Alix so it will come up with a web interface.

    Steve



  • I have re-write the new image using dd in backtrack, when i power Alix i think its working because the three leads is blinking simultaneously just like before, i tested the serial cable on my windows 7 ultimate and it was detected and hyperterminal also detects it.
    Do i i need to change something on the cf card image?



  • Hi Stephen,

    I did what you advise, I bootup BT 5 on a thumdrive, my USB to serial got detected, i use /dev/TTYUSB0 for the port, please see below. But still cant see anything on the screen, like bootup from Alix


  • Netgate Administrator

    The Alix bootup messages will be at 38400bps unless you've changed the BIOS setting.
    Do you have a link to exact null modem cable you bought?

    Steve



  • I did set it already to 38400 but same issue , no bootup on the screee. Below is the link where i bought my null modem cable

    http://www.ebay.com/itm/390248186240?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1439.l2649


  • Netgate Administrator

    Hmm, that listing does not appear to state that the cable is wired as a null modem. I think you're going to have to test it to make sure. If its wired correctly pin 2 at one end should be connected to pin 3 at the other end.
    See: http://en.wikipedia.org/wiki/Null_modem

    Steve



  • @stephenw10:

    Hmm, that listing does not appear to state that the cable is wired as a null modem. I think you're going to have to test it to make sure. If its wired correctly pin 2 at one end should be connected to pin 3 at the other end.
    See: http://en.wikipedia.org/wiki/Null_modem

    Steve

    Sorry for late reply, so thats why it still did not work.  I thought i bought a null modem cable.


  • Netgate Administrator

    It isn't necessarily the wrong cable, I would expect a female-female serial cable to be wired as a null modem. However you need to be sure since if it's wrong you'll never see anything on the terminal.

    Steve



  • Hi Stephen,

    Thaks for the response, here is how i connect it and the actual look of my female to female serial modem, connected to USB to serial


  • Netgate Administrator

    It looks like the right cable but I have no way to tell how it's wired. If it is wired as a null modem I would expect it to be advertised as such. The fact that it isn't makes me suspect it. Like I said if it isn't a null modem cable that would explain all the problems you've been having.

    You can easily test it if you have access to a multimeter and a paperclip. Any self respecting geek should have a multimeter!  ;)

    Steve



  • Hey Stephen you were right! The cable i bought was not a null modem cable, so i ordered again sometime like 3 weeks ago it just came earlier and tested the new null modem cable , it worked.  Im now setting  up pfsense webgui. Below is my config my current adsl modem/router is setup as DHCP, and i configure pfsense WAN to DHCP, when i test for internet it didnt connnect internet, do i have to disable dhcp on my modem/router, and enable only dhpc on pfsense WAN as DHCP ?

    adsl modem/router : setup DHCP

    pfsense
    WAN: DHCP
    LAN: 192.168.1.1 /24


  • Netgate Administrator

    Ok, so are you connecting the pfSense box behind the adsl modem/router?
    How did you test for internet on the pfSense box?

    There is a good chance that your adsl router is also using the 192.168.1.1 subnet for its LAN. This will break routing, you can't have the same subnet on two of pfSenses interfaces. If that is the case try changing the pfSense LAN subnet.

    Steve



  • ok so i will change the subnet, also do i have to disable the dhcp in my adsl router /  modem? and only enable dhcp in pfsense ( alix 2D3 ) instead?


  • Netgate Administrator

    Ideally you would place the modem/router in bridge mode in which case dhcp would be disabled.
    However initially if you're setting up pfSense behind the router just leave the router in its working configuration. Switch to bridge config later once you're up and running.

    Steve



  • Hi Stephen i did the following changes, but i still cant get into the internet.

    ADSL router / modem setup

    • set it to bridge

    • disable dhcp

    • LAN IP is 192.168.1.1

    PFSENSE CONFIG

    • set LAN IP 192.168.1.2

    • dhcp server subnet 192.168.1.10 - 192.168.1.245

    • DNS i use google 8.8.4.4; 8.8.8.8

    • set gateway 192.168.1.2

    Screenshots

      >> this config is in my adsl /mode router
      >> pfsense config
    >> pfsense config




  • Netgate Administrator

    192.168.1.1/24 is still in the same subnet as 192.168.1.2/24.
    Try changing the pfSense LAN to 192.168.2.1/24.

    Steve



  • Hi Steve,

    I set pfsense LAN IP 192.168.2.1
    default GW : 192.168.2.1

    I was able to nslookup outside but cant ping outside, i checked dhcp on WAN is releasing public ip, is my default GW correct? or it should be the LAN IP of adsl / modem router?



    adsl/modem
    LAN 192.168.1.1
    DHCP: DISABLED
    TYPE: bridge


  • Netgate Administrator

    Ok. You should not have a gateway on the LAN interface,
    Go to Interfaces: LAN: and remove it. Then goto System: Routing: and make sure your WAN gateway is the only one there and is set as default.

    It looks like you successfully set the router in bridge mode and it has passed your public IP to the pfSense WAN interface so you're all good there.  :)

    Steve



  • thanks steve, so WAN gateway would be 192.168.2.1 ?


  • Netgate Administrator

    Nope the WAN gateway is assigned by your ISP.

    It's your clients on the LAN network that should be using 192.168.2.1 as their gateway. That is handed to them from pfSense via dhcp. The only place that should be entered in pfSense in the the dhcp server setup for the LAN.

    Steve



  • hey Steve it Worked! thanks to your help and patience!! Enjoy your Holidays!


  • Netgate Administrator

    No problem, enjoy your new setup.  :)

    Steve


Log in to reply