Help Can' Get WPAD to work on squid on pfsense



  • Morning  All  need some  help  getting WPAD to work  with squid  on Pfsense 2.1.

    The setup we have is one  connection  for  WAN  that goes through a proxy provided by our  local education authority.one connection  for  the LAN  which is connected to the guest wireless.  the set up works as is if you manually put the proxy settings into the browser of the client laptop.  but does not  work if you tick  auto detect settings on the laptop. Have  placed  wpad.da and the proxy.pac files in the www folder as per the setup instructions.  I have attached  screen shots  to get advice where I am going wrong

    I have a week left till this goes  live any help would be appreciated so much.

    ok update

    I have found a thread on here that says to use DHCP  which I have done  and  I can now get it to work  if I put the wpad details in to the  use auto configuration script. this is better but not ideal. if any one can  help me get the settings  to work  auto detect the settings  I  will be so great full
    ![Squid set up.jpg_thumb](/public/imported_attachments/1/Squid set up.jpg_thumb)
    ![Squid set up.jpg](/public/imported_attachments/1/Squid set up.jpg)
    ![WPAD Settup.jpg_thumb](/public/imported_attachments/1/WPAD Settup.jpg_thumb)
    ![WPAD Settup.jpg](/public/imported_attachments/1/WPAD Settup.jpg)
    ![Firewall rules.jpg](/public/imported_attachments/1/Firewall rules.jpg)
    ![Firewall rules.jpg_thumb](/public/imported_attachments/1/Firewall rules.jpg_thumb)


Log in to reply