Нет доступа к FTP из внешней локальной сети



  • Попытаюсь объяснить без рисования схемы сети. Все очень просто. В качестве домашнего маршрутизатора установлен PFsense 2.1 на отдельной выделенной машине. Интернет от провайдера приходит по Ethernet 192.168.xxx.xxx\24. Также оплачен и давно используется белый IP. Внутри домашней сети крутится NAS на OMV также на отдельной выделенной машине, его адрес 192.168.0.100. На NAS поднят FTP. Порты для активного и пассивного режимов FTP в PFSense проброшены. Проблема в том, что NAS виден и доступен извне по белому IP, но не виден и недоступен из сети провайдера по 192.168.xxx.xxx\24.



  • не виден и недоступен из сети провайдера по 192.168.xxx.xxx\24

    А ваш провайдер локалку предоставляет?



  • У вас двойное (или) русское подключение? Галка о блокирование "серых" сетей снята?



  • @aleksvolgin:

    А ваш провайдер локалку предоставляет?

    Сегодня звонил администратору провайдера. Он сказал, что с  их стороны никаких ограничений нет.

    @werter:

    У вас двойное (или) русское подключение? Галка о блокирование "серых" сетей снята?

    По поводу русского двойного\подключения не понял.
    Про галку не в курсе. Если Вы имеете в виду чекбокс "NAT Reflection mode for port forwards", то сейчас там выставлен режим Enable pure NAT.



  • Вот целая ветка - http://forum.pfsense.org/index.php/topic,24734.0.html . Спросите там.

    Про галку не в курсе. Если Вы имеете в виду чекбокс "NAT Reflection mode for port forwards", то сейчас там выставлен режим Enable pure NAT.

    Если не знаете зачем оно - оставьте там Disable.

    По поводу русского двойного\подключения не понял.

    Это значит иметь на WAN "серый" адрес от провайдера, а для выхода в Инет дополнительно поднимать pptp\pppoe\l2tp-сессию.



  • @werter:

    Это значит иметь на WAN "серый" адрес от провайдера, а для выхода в Инет дополнительно поднимать pptp\pppoe\l2tp-сессию.

    В таком  случае у меня "нерусское" подключение. Мой WAN имеет внутрисетевой серый и наружный белый IP-адреса без поднятия сессий.

    Добавлено 30.10.2013 в 18:26
    Нашел, в чем была проблема. Как и писал уважаемый werter, необходимо было в настройках PFSense включить доступ с серых IP-адресов. Делается это в пункте меню "Interfaces" -> вкладка "WAN" -> снять галку с чекпоинта "Block private networks". После этого все поперло.
    Спасибо всем, кто уделил время на прочтение ветки. Надеюсь, кому-то тоже поможет.


Log in to reply