NUT Package



  • Hi!

    Habe meine USV (APC Back-UPS BE550G) via USB an meinen Server angschlossen, das NUT Package installiert. So weit funktioniert das auch, der NUT Status zeigt die USV als "online" an. Leider findet mein NAS die USV nicht!

    In den NUT Einstellungen steht folgender Hinweis: The new default is to bind to localhost ONLY - you should add NAT rules for the NUT port (3493) to allow remote access.

    Dem entsprechen habe ich folgende Regel angelegt:

    Firewall: NAT: Port Forward
    If:  LAN
    Proto:  TCP
    Src. addr:  *****
    Scr. ports:  *****
    Dest. addr:  10.0.0.1  (IP der pfSense)
    Dest. ports:  3493
    NAT IP:  127.0.0.1
    NAT Ports:  3493

    Der Port ist auch offen!

    Am NAS habe ich UPS Slave eingestellt, IP des Netzwerk UPS-Server:  10.0.0.1. Leider "sieht" das NAS die USV nicht.

    Weiß jemand Rat für mich?

    Danke vorab.

    Lg
    esquire1968



  • Hallo esquire1968,

    der Text liest sich so, dass ein Qnap-NAS als Slave an einen pfSense-Master angebunden werden soll, an dem ein APC-UPS mit einem USB-Kabel angeschlossen ist.

    Dies würde ich ebenfalls gern hinbekommen. Gibt es dafür eine Lösung?

    Vielen Dank

    Michael Schefczyk



  • Hab leider nicht hinbekommen, weder mit dem Package Apcupsd noch mit Nut.

    Die pfSense erkennt die USV, das NAS (als slave) nicht.

    Wenn Du auf eine Lösung kommst, bitte posten.

    LG


  • Moderator

    @esquire: Hast du im Nut Package denn User/Pass vergeben und macht das QNap die Einstellungen mit? Das Nut Package ist eigentlich recht flexibel, hört sich für mich danach an, dass Qnap hier spezielle Einstellungen voraussetzt.

    Bei Synology habe ich es umgekehrt bereits am Laufen: Die Synos können ja eine USV direkt anbinden (auch eine APC550 in meinem Fall) und an andere Synos weiterreichen. Dazu kann man die entsprechenden IPs (bis zu 5) in eine Liste eintragen. pfSense IP mit eingetragen und dann in den Sourcen von Syno geschaut, mit welchem User/Pass hier das NUT Package läuft.

    Diese Daten in die Nut Einstellungen der pfSense eingetragen und BOING, läuft.

    Evtl. kannst du es ja auch mal anders herum versuchen, ob die pfSense als Slave am NAS läuft?



  • Bei Qnap scheint gemäß Source Code NUT mit Benutzer "admin" und Passwort "123456" im Einsatz zu sein. Das Zusammenspiel funktioniert, wenn pfSense der Master ist, an den die USV angeschlossen wird und das Qnap-Gerät der Slave. Dann muss man lediglich

    • im pfSense die oben beschriebene Firewallregel anlegen
    • im pfSense im NUT-Paket einen Remote Access User "admin" anlegen mit Remote Access Password "123456"
    • im pfSense unter Local UPS Settings den Local UPS Name "qnapups" wählen und die anderen Einstellung so wählen, dass das lokal angeschlossene USV erkannt wird.
    • im Qnap-Gerät "Netzwerk-UPS-Slave" wählen und die IP der pfSense eingeben.

    Michael Schefczyk