Pfsense 2.1-Release (AMD64) on Hyper-V 2012 R2



  • Hi all

    Since the release of Hyper-V 2012 R2 adds substantially more Linux support, I was wondering if anyone tried if things has improved for BSD on Hyper-V?

    I would love for Pfsense 2.1-Release to run on a 2012 R2 Hyper-V, but I haven't got much time to play around with it right now. So any experiences would be welcome.

    -Keyser



  • If you haven't seen it, check out http://forum.pfsense.org/index.php/topic,56565.msg364122.html#msg364122 for ISO images to install pfSense with Hyper-V support. YMMV.

    AFAIK, WSrv12-R2 doesn't include a new version of the Integration Services for BSD -and even if it did, I don't know how you'd go about installing them in a running pfSense install, it likely doesn't have all the required components-, so it is up to the FreeBSD on Hyper-V open source project to release updates. There likely have been improvements in this port (the source patch we're using in the build is over 1 year old). Maybe next month I'll try to see if I can incorporate those fixes in the build process. Meanwhile, you could try the current build to see if it works for you, and post your experiences in that thread.


Log in to reply