Local/private esx-setup with rdp forwarding into vm's



  • Hello together,
    as you can see in the headline - I want to setup a local esxi 5.1 infrastructure for testing purposes - no routers, only static ip adresses.

    My setup consists of a physical server that runs with vsphere 5.1 hypervisor, has 1 physical nic, and hosts some virtual machines running windows (server 2012r2 and client 8.1). In addition to that physical server, I have a physical notebook on which I installed the vSphere client to connect to the host (they are connected via cable [no switch, hub or anything]).

    My intention is to connect directly into the vm's via rdp from the notebook.

    So I tried it with a pfSense-vm that acts as a router - but until now, I can't get it working - maybe anyone can help me.

    My esx host: 192.168.16.1 / 24

    My notebook with vsphere client 192.168.16.2 / 24

    On the esx host I created 2 networks - the default vSwitch0 that is connected to the vmnic0 and a second vswitch1 that has no physical adapter assigned.

    Then I created a winserver vm, enabled rdp and assigned a static ip of 10.10.10.2 / 24

    Then I created a pfSense-router-vm, which then has a "wan-interface" with a static ip adress of 192.168.16.3 / 24 and is assigned to the vSwitch0-network-interface from the configuration and a "lan-interface" with a static ip-adress of 10.10.10.1 / 24 that is assigned to the vSwitch1-network interface from the configuration.

    After that, I was able to enter the configuration of pfsense from a browser opened within the winserver vm. then I did some settings, e.g. de-activating the "block private networks" setting for the "wan-interface". and of course I created a port-forward rule, that forwards rdp requests from 192.168.16.3:3395 to 10.10.10.2:3389.

    Unfortunately the rdp connection doesn't work.

    Is it a simple mistake I made - or has anyone any other suggestion for me?

    I really appreciate your help guys - thanks in advance.



  • No one any tips?

    :(


  • LAYER 8 Global Moderator

    Curious why your changing ports in your forward from 3395 to 3389?  You sure you actually told your rdp client to connect to port 3395?

    Here
    https://doc.pfsense.org/index.php/Port_Forward_Troubleshooting

    And also if still having issues - post up screens of your rules so we can see what your doing wrong.. Have source port set is common mistake.

    You sure its not just local firewall of where your trying to rdp too - this is another common mistake.  Your off that boxes local lan, so its firewall most likely is not going to have that open.  Unless you set it to be.


Log in to reply