Solucion para portal cautivo



  • buenas noches estoy utilizando portal cautivo y freeradius y tengo todo configurado de maravilla pero el unico problema que se me presenta es que cuando lo activo si me detiene el internet hasta que me logeo pero no me aparese la pagina para logearme tengo que poner manuelmente en el navegador esto: http://192.168.0.1:8000/ y asi ya acepto los terminos y condiciones y luego pongo mi usuario y contraseña para poder tener acceso a internet
    alguna solucion para que en vez de poner manualmente la direccion del pfsense que me pida logearme en automatico





  • soy demaciado torpe no comprendo que es lo que tengo que hacer ya revise el contenido lo traduje pro no veo posible solucion que es lo que tengo que hacer?



  • DNS resolution not functioning - the clients on the captive portal interface must either be using the DNS forwarder on pfSense, on the IP of the interface where the client resides (which is the default configuration), or if using some other IP for DNS, it must be an allowed IP entry. If DNS fails, the browser never issues the HTTP request, hence it cannot be intercepted and redirected.

    Para que se cumpla esto, lo más simple es que los clientes tomen su IP con el DHCP de pfSense y que, a su vez, pfSense sea su servidor DNS. Verifica la configuración IP otorgada a tus clientes mediante comandos:

    Linux
    ifconfig
    nmcli dev list iface eth0 | grep IP4

    nm-tool

    Windows
    ipconfig /all

    Firewall rules on the captive portal interface do not allow the initial HTTP request - if the user is trying to browse to google.com, but you're not allowing HTTP to google.com, the HTTP request will be blocked and hence cannot be redirected. Under Firewall>Rules, on the interface where captive portal is enabled, you must be allowing the traffic that you want to be redirected (most commonly HTTP to any destination).

    Tus reglas deben permitir el tráfico http. Deshabilita el portal cautivo y prueba que sea así.


Log in to reply