Virtual computer up unable to ping router or get out to wan



  • I have my pfsense set to 192.168.1.1

    dynamic range is from 192.168.1.50 to 70

    My vmware server is set to 192.168.1.101 (static)

    I am using a cisco|linksys auto switch

    I can't ping 192.168.1.1 from the virtual server.. besides swapping out cat5 cable and using a different switch?

    Any thoughts guys?


  • Rebel Alliance Global Moderator

    That is great you statically set your VM, but how is it connected to your physical network?  When you say vmware server you mean what.  A box running esxi (vsphere) a box running vmware server software, a server as a VM inside a vmware?  Player, Workstation,?

    Really need some more details to work with here.



  • esxi 5.0 physical server :)



  • I swapped out the firewall.. and I still cant ping the the vmware computer… i am pretty sure its a firewall related issue.. one time it worked..


  • Rebel Alliance Global Moderator

    Ok I run esxi 5.5 and have no issues..  Again – is that IP address your esxi vmkernal port IP?  How do you have your esxi configured networking.

    Are you talking the firewall of the esxi host, or VM host -- the default rules for pfsense lan, allow pinging of the lan IP.  I have not seen a host firewall block outbound traffic by default.

    Again - Details or how are we suppose to help you?

    Example here is mine esxi network config, I have my esxi firewall off - serves no purpose on my secure lan, etc.

    You can disable esxi firewall with this command
    esxcli network firewall set --enabled false

    You can view status of it with the command you see in pic.

    So you see in the pic my esxi vmkern IP is using physical nic vmnic0 that is connected to my phsyical lan via a switch.  And that is the IP I use to manage esxi via the client, command line, etc.

    You will then see the vswitch3 which is physically connect to vmnic2 also connected to my physical lan via that nic.  This has most of my vms and one leg of pfsense vm router.  You also notice the wan and wlan switches.  So WAN goes to my cable modem via vmnic1, and wan leg of pfsense.  WLAN switch is connected to physical world via vmnic3 and this connects my APs, and pfsense wlan nic.  So I can run wireless on different network segment.  I need to pull that vNios vm off that - thats wrong switch ;)

    So can we get such details of your setup, and then we can help you figure out what it wrong.  You saying VM can not ping pfsense IP gives us nothing to work with.

    I am currently on my physical workstation, 192.168.1.100 and I can ping both the vmkern IP and pfsense lan IP 192.168.1.253 which is a vm with its virtual nic connected to my lan vswitch which in turn is connected to my physical network switch via vmnic 2 and my workstation is connected to another physical switch that is connected to the physical switch that esxi is connected to.