WebGUI. Проблема новичка



  • Добрый день. Возникла проблема со входом в веб интерфейс.

    Установил pfSense 2.1.

    Начал начальную настройку, отказался от VLan'a.
    У меня 2 карточки:

    re0 RealTek 810xE PCIe 10/100baseTX
    rl0 D-Link DFE-530TX+ 10/100baseTX

    Карточка смотрящая в инет(провод от роутера) WAN - re0
    Карточка LAN (к которой подключена точка доступа) - rl0

    Все поставилось.
    WAN -> re0 -> v4/DHCP: 192.168.1.17/24
    LAN -> rl0 -> v4: 192.168.1.1/24

    Получаем по дефолту ip для веб интерфеса 192.168.1.1, но такой ip стоит у роутера.

    Поэтому в pfSense выбираю пункт 2 -> enterv -> выбираю LAN -> enter

    Enter the new LAN IPv4 address.  -> я пишу 192.168.1.20
    Enter the new LAN IPv4 subnet bit cont: -> я пишу 24, т.к. маска подсети 255.255.255.0
    Enter the new LAN IPv4 gateway address -> я пишу 192.168.1.1 (шлюз роутера)
    Enter the new LAN IPv6 address -> просто жму Enter
    Do you want to enable DHCP server on LAN? Кликаю y и жму enter
    Enter the start address of the IPv4 client address range:  192.168.1.2
    Enter the end address of the IPv4 client address range: 192.168.1.100
    Do you want to revert to HTTP as the webConfigurator protocol: YES

    bla bla bla
    You can now access the webConfigurator by opening the following URL in your web browser: 192.168.1.20

    На ноуте подключенному по шнурку к роутеру подключиться не удается.

    Помогите пожалуйста, где и в чем запутался.
    П.С. Делаю маленький хот спот для кафе друга, где просто нужно редиректить на страницу с рекламой.

    Спасибо за внимание

    В прошлых установка, когда настраивал vlan, удавалось подлючиться в webgui по вай фай. Сейчас ничего не получается :(



  • Я бы для начала вообще wan не настраивал. Просто Lan и уже оттуда цепляться на вебморду. Сам такой глюк ловил, вроде просто оставил LAN, настроил и перегрузился.



  • @NetWiz:

    Я бы для начала вообще wan не настраивал. Просто Lan и уже оттуда цепляться на вебморду. Сам такой глюк ловил, вроде просто оставил LAN, настроил и перегрузился.

    Я так и сделал, поставил только LAN. Теперь по вай фай могу законнектиться на 192.168.1.1
    Ввожу логин и пароль, захожу, после чего Веб интерфейс снова не доступен :(

    На сервере пишет Succesful login for user  'admin' from 192.168.1.14

    после перезагрузки pfsense, снова могу зайти в веб интерфейс и ввести логин и пароль и все :)
    Может дело в том, что у роутера 192.168.1.1 и y pfsense lan 192.168.1.1 ?

    Thanks

    Woohooo! Заход решился сменой айпи на 192.168.1.17



  • А ничего что у вас и LAN и WAN из одного диапазона? Меняйте адрес LAN на тот же 10.х.х.1/24 или 172.х.х.1/24.

    И роутер, стоящий перед Pfsense, переводите в режим моста\точки доступа. Пускай pf поднимает сессию\является первым на пути к Интернету . Зачем вам двойной NAT.



  • Ну может он не /24 будет маску использовать…



  • У меня просто дома интернет адсл. Телефонный шнурок воткнут в роутер модем.
    Если я его поставлю в режим моста роутер, то потом смогу с помощью точки доступа исходящей из pfsense раздавать интернет?
    Маленький вопрос: wan должен быть кабель от роутера в сервер или от второй карточки в точку доступа?

    Просто когда ван кабель от роутера, то по ай пи не зайти в веб морду!
    Надеюсь объяснил понятно :)
    Спасибо!



  • @Vova:

    У меня просто дома интернет адсл. Телефонный шнурок воткнут в роутер модем.
    Если я его поставлю в режим моста роутер, то потом смогу с помощью точки доступа исходящей из pfsense раздавать интернет?
    Маленький вопрос: wan должен быть кабель от роутера в сервер или от второй карточки в точку доступа?

    Просто когда ван кабель от роутера, то по ай пи не зайти в веб морду!
    Надеюсь объяснил понятно :)
    Спасибо!

    Не совсем. Рисуйте схему со всеми адресами.



  • Порыв инет и прочитав коммент выше, понял, что надо изменить айпи роутера и поставить его в бридж!
    В голове такая схема.



  • Пойдет. Реализовывайте.



  • Добрый день.
    Сделал все по инструкции.

    У роутера-модема остался адрес 192.168.1.1 (bridge mode)
    У pfSense
    WAN -> re0 -> 192.168.1.2/24 (шнурок от роутера в сервер)
    LAN -> rl0 -> 172.16.1.1/24 (шнурок от сервера в AP)

    Точку доступа -> 172.16.1.2 с DHCP.

    Все подключается, все работает. Только не могу настроить интернет.
    На роутере было подключение PPPoE с логином и паролем, VPI, VCI.

    В pfsense добавил PPPoE сервер, но подключение в интернет настоить не получилось.

    Подскажите пожалуйста куда смотреть, что бы настроить интернет. Спасибо

    Нашел в настройках интерфейсов IPv4 Configuration Type надо поставить PPPoE.
    Сейчас буду пробывать с логином и паролем настроить.
    Вопрос: что бы интернет развать с точки доступа, PPPoE надо настраивать на LAN или WAN? Спасибо



  • На WAN



  • WAN теперь имеет айпи 151.67.218.180.
    Но что то с лана интернета как не было, так и нет. Может надо настраивать firewall?

    Сейчас пришлось отдать CD-ROM, без него система не стартует.
    Спасибо

    Поставил новый CD-ROM, а за одно и новую систему. Настроил WAN на PPPoE и LAN.
    И чудом все заработало.
    Понимаю, что уже далеко зашел за рамки темы, но пользуясь случаем хочу спросить,
    DHCP надо ставить на LAN или уже на точках доступа? Спасибо



  • На LAN пфсенса DHCP включите, на точках доступа (ТД) - отключите DHCP. И кабель от pfsense в LAN на ТД воткните (или если ви-фи роутер "по-умнее" - просто переведите его в режим ТД) , чтобы подключающиеся клиенты получали сетевые реквизиты от pfsense.