OpenVPN no comunica



  • Estimados,
    Agradecería su ayuda con este asunto, ya se me acabaron las ideas.

    Necesito conectar una sucursal a la empresa donde trabajo.
    Tengo dos pfSense 2.1

    openVPN esta configurada en ambas maquinas, de echo indican que se ven y están activas y unidas.
    Como están conectados, asumo que 'General information' y 'Cryptographic Settings' están correctos.
    Los log no indican errores.

    Sin embargo no pasa un ping entre un equipo y otro, no se ven…

    La figura es :

    ServidorX 128.1.0.55/16
        openvpn-server  IPv4 Tunnel Network      10.0.8.0/24
        openvpn-server  IPv4 Local Network          128.1.0.0/24
        openvpn-server  IPv4 Remote Network/s  128.1.34.0/24
        openvpn-server  Rules-OpenVPN    IPv4 * * * * * * none  (regla creada)
            internet (F.O.)
                vpn
            Internet (bam Huawei)
        openvpn-client    IPv4 Tunnel Network      10.0.8.0/24
        openvpn-client    IPv4 Remote Network      128.1.0.0/24
        openvpn-client    Rules-OpenVPN    IPv4 * * * * * * none  (regla creada)
    Pc  128.1.34.100/16

    El Pc navega y todo, la Bam Huawei funciona correctamente.

    Da la impresión que no ruteara por donde debe, pero probé agregar un ruteo a mano en 'Advanced configuration' y nada.

    Se agradecen sugerencias.

    Antonio



  • Estás intentando unir dos LANs por OpenVPN? O un cliente externo a tu LAN en la empresa?

    Donde está físicamente la red 128.1.34.0/24 que seteaste como Remote Network?

    Por cierto, que rangos feos!! Esos rangos de IP son públicos, para tus redes internas deberias usar alguno de los rangos definidos para tal por RFC1918



  • Hola, gracias por contestar.

    Efectivamente feo rango, data del 1995 app, y cambiarlo hoy es tema mayor…
    Esta en los pendientes...

    Respecto a la VPN, es una VPN 'Site to Site'  esta la central y esta es una sucursal, dos firewall pfsense con las mismas versiones...
    La 128.1.34.0/24 esta precisamente en la sucursal.

    Servidor:  local  x.x.0.0/24  remota x.x.34.0/24
    Cliente  :                              remota x.x.0.0/24

    Saludos.

    A.



  • Pusiste que la "PC" es 128.1.34.100**/16**.

    Eso es correcto o es un error de tipeo? Porque si está configurado así ese es el error



  • @georgeman:

    Pusiste que la "PC" es 128.1.34.100**/16**.

    Eso es correcto o es un error de tipeo? Porque si está configurado así ese es el error

    Correcto 128.1.34.100 /16, para que alcance a ver un equipo ej. 128.1.0.42 , así que 2 octetos abierto…

    En todo caso probé configurar el pc-cliente como 128.1.34.100/24 que creo es tu observación, y tampoco funciona.

    También una opción en Open-VPN -> Client specific Overrrides -> Tunnel Settings -> [Tunnel Networks] y [Redirect Gateway]  …
    Sin éxito...

    Gracias.
    A.



  • Tienes un problema basico de ruteo. Ahora veo que el servidor también esta puesto como 128.1.0.55/16

    La máscara de subred indica los equipos que son accesibles sin pasar por ningún gateway. En este caso, configurando algo en /16 le estás diciendo que la red remota es accesible directamente a nivel de switch, cuando en realidad es una red separada accesible a traves del gateway (pfSense en este caso)



  • @georgeman:

    Tienes un problema basico de ruteo. Ahora veo que el servidor también esta puesto como 128.1.0.55/16

    La máscara de subred indica los equipos que son accesibles sin pasar por ningún gateway. En este caso, configurando algo en /16 le estás diciendo que la red remota es accesible directamente a nivel de switch, cuando en realidad es una red separada accesible a traves del gateway (pfSense en este caso)

    Ok gracias.
    Entiendo el punto.
    Cerré todo a  /24
    Reinicie los servicios de vpn en ambos lados…. y nada.

    Lo único que queda es la ip de la interfaces LAN en FW-Server ... esta en 128.1.1.1/16
    Y no puede cambiar...

    :(



  • Entonces es correcto que no funcione, ya que el firewall cree que la IP remota es una IP local…

    Sugiero que reveas la configuración general de tu red para tener algo más prolijo, de lo contrario solo vas a obtener dolores de cabeza...



  • Gracias, ya lo tengo andando. No como necesitaba exactamente pero la OpenVPN anda (y motivo de la consulta).
    Ahora veo el pfsense estaba bien configurado, el problema era de las direcciones…

    Gracias georgeman por tu tiempo, efectivamente comenzare a re-pensar mi red, aunque con 30 sucursales no es algo muy trivial que digamos...

    Saludos.
    Atte.

    Antonio