2.1 Enabling 802.1x Authentication



  • Hello,

    I am attempting to enable 802.1x authentication on a Netgate 2D3 (ALIX 2D13) w/ a Wistrom CM9 (Atheros 5004) wi-fi card running pfSense 2.1. I can use wi-fi successfully with no authentication or WPA-PSK, but when I switch to 802.1x, my AP becomes accessible without any authentication at all.

    If I choose these settings below, the AP becomes wide open for anyone to connect without any authentication:

    WPA Enabled
    WPA Key Management Mode: Extensible Authentication Protocol
    Authentication: Shared Key Authentication (have also toggled to Open)
    Enable IEEE802.1X Authentiation
    802.1X Authentication Server IP Address: Entered
    Shared Secret: Entered

    Any thoughts?

    Thanks,
    Preston



  • I've just stumbled across your post. I am having a similar problem under pfSense 2.1 with my ALIX.2D13 and an Atheros AR5413 WLAN card. I am using authentication against a radius server (IEEE802.1X) as well. Sniffers always show the access point as open. I am, however, not sure if I can connect with my wireless clients - I will have to investigate it again. Until now I've supposed my problems might be related to the cloning of my WLAN interface. But of course, it could be IEEE802.1X related. My WLAN card does not produce any logging information  under pfSense 2.1. You can find details in this thread: http://forum.pfsense.org/index.php/topic,68531.0.html.

    Does your WLAN card produce any logging output under  /var/log/wireless.log? Mine doesn't.

    Currently I have not enought time to investigate the problem. As all WLAN problems disappear with pfSense 2.0.3 I am still staying with this version. If I find some more information I will continue my above thread.

    Regards,
    Peter



  • Thanks for the note, Peter. I had just assumed that the AP WAS open when it showed open, but I'm not sure if I tried to actually connect to it.

    I will check the above as well as the log later this evening and post back.

    Preston



  • Did you solve this? I am facing the same issue now on version 2.1.3.



  • @lbm_:

    Did you solve this? I am facing the same issue now on version 2.1.3.

    If you have addressed me: Yes, it is solved and in particularly for 2.1.3. You can find here some more detailed information:
    https://forum.pfsense.org/index.php/topic,68531.0.html

    Regards,
    Peter


Log in to reply