Pfsense as a router and default gateway with multiwan

  • Hello
    I'm fresh in pfsens, so sorry for that question, but I really tried to find out the answer on this forum/gogle but no solutions found…
    Here is an example of my network.

    PfSense works as a router and default gateway;
    Static routes for gw: descr lan10 gw: descr lan50 gw descr lan32

    LAN rules looks like this for every single IP of my whole networks ie: (i use aliases)

    • | | port: * | dest: * | gateway: DEFAULT [use in/out for that IP]
    • | | port: * | dest: * | gateway: DEFAULT [use in/out for that IP]
    • | | port: * | dest: * | gateway: DEFAULT [use in/out for that IP]
    • | | port: * | dest: * | gateway: DEFAULT [use in/out for that IP]

    At pfSense I added a gateway ( and traffic between networks and pfSense works great when I use only one WAN int.

    How can I configure pfSense to use MulitWAN (; ) Because if i set rules default Gateway: ‘multiWAN’ (WANPPPoE1 Tier1 and WANPPPoE2 Tier1):

    • | | port: * | dest: * | gateway: multiWAN [use in/out for that IP]
    • | | port: * | dest: * | gateway: multiWAN [use in/out for that IP]

    ..There is no trafic to static routes.

    Best regards
    bravo prochu

    ![PFSense network.jpg](/public/imported_attachments/1/PFSense network.jpg)
    ![PFSense network.jpg_thumb](/public/imported_attachments/1/PFSense network.jpg_thumb)

  • I have the same problem, have you solved it?

  • No, i did not;

    Still searching…
    I guess it's impossible on pfsense;

    Right now i'm considering changing my whole networ into bridge and vlans ...or drop pfsense.

  • @bravo_prochu:

    No, i did not;

    Still searching…
    I guess it's impossible on pfsense;

    Right now i'm considering changing my whole networ into bridge and vlans ...or drop pfsense.

    mmh… do you both used the search function of this board with the right keywords? ;)  just ready some posts "before"


    So if you put all your 4 WAN connections into a group and all gateways have the same Tier then these do loadbalancing and if one GW hoes down the other 3 WAN connectiongs do loadbalancing.

    If you use "Sticky connections" on SYSTEM –> ADVANCED then this one group will be enough.
    If you do not use sticky connections you should create another group which will handly traffic for https and other secure protocols because https and other secure connections do not like loadbalancing because the IP switches.

    I guess that your routing problems comes also from non-sticky loadbalancing connections…

    BTW: if you want monitor your sub-networks there was found a "fix" for it:,69443.0.html


  • I have something similar configuration  but i have layer3 switch instead of your routers and pfsense is working as gateway with 5 wans,
    each and everything is going fine.

    In interfaces LAN, do not select any gateway just leave it blank.
    hope this will fix your problem!

  • why do you have 2 pfsense machines in the first place ? unless i'm missing something (i generally do), i don't see any reason for that pfsense between the ppoe-pfsense and the lans ?

    After closer inspection i concluded i have no clue what you are trying to accomplish by putting 2 routers behind each other, and then using 4 additional routers lateral of each other, pointing to the X.X.10.X gateway (router2).

    So i'm fairly confident it is possible to make it work somehow … we probably need more info to sort out what goes wrong.
    If it works for 1 WAN, but does not for 2 WANs then you should probably look at a NAT issue. => disable automatic NAT (AON)
    and create your own nat rules as needed.

  • Hello

    That is how my network works. I use routers (with disabled nat function) and pfSense works as a 'NAT serwer' (in a future dhcp serwer too)
    Everything works great when I use only one (default gateway);

    To make it multiWAN works I need to specify default gateway in firewall rules and thats the problem, because when I point 'mulitWAN' gateway - there are no traffic (out) from static routes. [with static routes - there are mulit LAN gateways]

    Disabling AON, to do what ?

  • Rebel Alliance Global Moderator

    "At pfSense I added a gateway ( and traffic between networks and pfSense works great when I use only one WAN int."

    Why would you set a gateway, that is not a WAN interface its a LAN interface - you would not set a gateway, you would only setup routes.

  • Did You ever try to set up static routes on pfsense ?

  • Rebel Alliance Global Moderator

    Have I?  Yes quite simple. You don't set gateways on LAN interfaces.

    If you would use a non 192.168 range between pfsense and your first router pfsense route table would be quite simple with one entry for

    Its seems you have a cluster of a setup there that seems way more complicated than it needs to be.

    LAN rules looks like this for every single IP of my whole networks ie: (i use aliases)

    • | | port: * | dest: * | gateway: DEFAULT [use in/out for that IP]
    • | | port: * | dest: * | gateway: DEFAULT [use in/out for that IP]
    • | | port: * | dest: * | gateway: DEFAULT [use in/out for that IP]
    • | | port: * | dest: * | gateway: DEFAULT [use in/out for that IP]

    What???  Every single IP has its own entry - WTF were you thinking?

  • Every single IP has its own rule entry, because I want to control bandwidth of every single alias-ip;
    I use limiters - for every IP - as many limiters as aliases (ip)

    How can I set static routes to routers without seting up geteways ?
    (i need a remote connection to devices behind those routers)

    I'm newbie so if You can, please, share an idea how to do it different way..

  • Rebel Alliance Global Moderator

    "How can I set static routes to routers without seting up geteways ?
    (i need a remote connection to devices behind those routers)"

    Yeah you set the routes here - see attached.  And yes in the routes you pick a gateway.. But you do not apply that gateway to your lan interface.  If you apply the gateway to the interface directly then pfsense thinks thats a wan interface.

  • I still don't understand: 'But you do not apply that gateway to your lan interface' ?
    First i needed to setup lan gateway (see attached - staticRoutes02) to pick it up to the destinated network (see attached - staticRoutes01)

  • Rebel Alliance Global Moderator

    But is that applied to your interface?

    Look - here is dummy gateway I created for network – it uses my DMZ interface.. But notice on the actual dmz interface there is NO gateway set!!

  • Gateway is on my LAN interface… so there is no 'gateway' for LAN int..

    What does it change ? Because I still don't get it..

    I would like to use multiwan tutorial, so when I specify default gateway in rules ('multiWAN' = PPPoE1 [tier1] and PPPoE2 [tier1]) there is no traffic to routers..
    (on attachement i don't  have created multiWan gateway yet but i already tried it)

  • Rebel Alliance Global Moderator

    "What does it change ? Because I still don't get it.."

    If there is a gateway on the interface - pfsense thinks its a WAN, and will auto nat it for starters.

  • There is no gateway on LAN interface, but still when I change default gateway on FIREWALL-RULES-LAN…alias..- gateway to multiWAN instead of default - there are no traffic

  • Not sure where you are up to, but here are the general principles when you have some internal networks and multi-WAN with gateway groups…

    1. Define a gateway for each other internal router (gateway) that leads to an internal network that is NOT directly connected to pfSense.
    2. Define a static route to each of these internal networks pointing to the correct internal gateway.
    3. Add gateway group(s) that group together your real public WANs in whatever tiers you wish.
    4. First add rules on LAN to pass traffic to the the internal networks - without specifying any gateway in the rules - the packets will be passed to the ordinary routing table and the static route/s you defined will get them to their destination.
    5. If you have VPN site-to-site links to other offices, these also need to use the ordinary routing table - put pass rules for traffic to subnets that are across the VPN, and let the ordinary routing table and VPN software deal with it.
    6. Further down in the LAN rule list, put rules that send traffic to particular gateway groups (e.g. near or at the end you might commonly have a rule that passes all protocols source LANnet destination any gateway LoadBalanceGWG - to load balance everything that did not match any previous special rule)
      Some screen shots attached of one of my setups, with a test Firebox internally that goes to various test subnets in The LAN rule passing INF_Subnets to INF_Subnets matches this Firebox traffic (among other stuff). INF_Subnets is an alias that contains all my internal subnets, local to pfSense, at the same office and across VPNs at other offices. This makes it easy to write 1 pass rule that lets all this internal private traffic pass through to the ordinary routing table, before any rules that pump traffic into a gateway or gateway group.

  • Rebel Alliance Global Moderator

    ^exactly – needs to be turned into a doc..  If I find time tmrw at work (its been slow normally as we get closer to holidays) I will do just that ;)

  • Thanks for Your answers Guys !

    Still have some questions
    I use limitters for every aliases (clients) (att.  staticRoutes06) on my network; My LAN rules looks like (att.  staticRoutes05)
    Instead of 'Private_devices' (block private devices to outside DNSserver) can I use all local subnets ??
    Do 'Inf_Subnets' have LAN subnet included ? (pfsense box IP) ?

    Can You help me with this ?

    How to drop any other stations to the Internet (but aliases..) and still have local connections to the lan routers/Access points using multiWAN..

    Can You point me a basic firewall isolation for that kind of policy ?

  • Instead of 'Private_devices' (block private devices to outside DNSserver) can I use all local subnets ??
    Do 'Inf_Subnets' have LAN subnet included ? (pfsense box IP) ?

    I have lots of different LANs, so I made some aliases like:
    'Private_Devices' = IP address ranges that I give out to private devices on the LAN (like people's smart phones…)
    'Inf_Subnets' = all the private subnets in my private extended network (includes LAN subnet and others)
    Then I can make easy rules to block or pass traffic to or from these groups of IP address subnets.
    If you just have 1 LAN subnet, then it is easy to just make rules like:
    Block UDP+TCP source LAN subnet, destination !LAN IP port DNS (53)
    That stops LAN clients getting DNS from anywhere else outside pfSense LAN.

  • Thanks for an explanation;
    So, i should use this rule at the top of my others ?
    then, the 'inf_subnets' and then - my 'aliases rules' ?

    As I wrote before I use one rule for one alias - to use bandwidth per IP tutorials; Right now my rule is - alias to 'any' [any port], but when first set to exclude 53 port to any devices on LAN subnet then i should use only [alias to any - DNS port (with multiWAN gateway)] rule ?

  • Yes, that rule (assuming it has "Block" selected at the top) goes up the top of your list. It will stop any port 53 (DNS) packets that are not going to the pfSense LAN address. So people won't be able to access other DNS servers out on the internet - they will have to use DNS provided by pfSense (or be extra tricky to find other ways around it).

  • Hi
    Tried to do exactly as You wrote, but it doesn;t work.
    I have to add rule any to any at the bottom of all my rules, can You help me understand why ?
    If I disable it - win7 gives me an 'Internet' access massage but there is no traffic to it

  • You often want a quite permissive rule at the end that feeds "ordinary" traffic into Multiwan GWG. That way most ordinary traffic ends up in the Multwan GWG, which you want. That is like your 2nd last rule, but the 2nd last rule has something special as source (which I can't read/guess since it is partly rubbed out). You need to modify the 2nd last rule so it actually passes traffic from all the sources you wish (maybe all of LANnet?) into Multiwan. Then the last rule is not needed.

  • My goal is to pass traffic ONLY from devices included in aliases… (partly rubbed out)
    I dont use dhcp serwer on pfsense. I would like to block all traffic exept aliases.. I guess there is something wrong in that policy because when i set a static ip - there is an Internet on it.. (even if ip is not in aliases list)
    what rules should I use ?

  • If you remove that last "pass all" rule, then (assuming there are no other rules like that) you will be just passing the things specified in the various aliases used in rules. If someone sets their IP address to one that is passed, they get internet. Set it to some other IP, then it will be blocked by the unseen default block rule (or whatever other block rule that might match before that). You really need to first know exactly what you want blocked and passed, then look through your rule list from top to bottom, think through what IP addresses are in which alias and make rules in order that will have the effect you want.

  • To easly modify network policy I would like to only add new rule with alias for example 'newCustomer' like in my pictures above;
    In that line I have IP or IPs of newCustomer devices (included in alias - newCustomer), set default gateway - 'MultiWAN' and  set limiters: newCustomerUP and newCustomerDown - to specify bandwidth
    For every single customer I would like to create that kind of rule to define different UP/DOWN speed (I add 2 limiters for every alias in my network)
    Is there any other way to do that ? Is it possible that the limiters slowing down speed traffic between lokal routers ?

  • Hello phil.davis !

    Can You help me to understand one more thing..
    I followed Your instructions and it works !! But i can't understand what is going on with traffic ballancing.
    I have 2 pppoe WANs 80/8Mbit vDSL2 and basically works only one of them (attach)
    Is it normal bahaviour ?

    I have chacked 'use sticky connections'

    best regards

    ![PFSense multiWAN 01.png](/public/imported_attachments/1/PFSense multiWAN 01.png)
    ![PFSense multiWAN 01.png_thumb](/public/imported_attachments/1/PFSense multiWAN 01.png_thumb)
    ![PFSense multiWAN 02.png](/public/imported_attachments/1/PFSense multiWAN 02.png)
    ![PFSense multiWAN 02.png_thumb](/public/imported_attachments/1/PFSense multiWAN 02.png_thumb)
    ![PFSense multiWAN 03.png](/public/imported_attachments/1/PFSense multiWAN 03.png)
    ![PFSense multiWAN 03.png_thumb](/public/imported_attachments/1/PFSense multiWAN 03.png_thumb)
    ![PFSense multiWAN 04.png](/public/imported_attachments/1/PFSense multiWAN 04.png)
    ![PFSense multiWAN 04.png_thumb](/public/imported_attachments/1/PFSense multiWAN 04.png_thumb)

  • The load balancing is random. So if you have just 1 client doing a big download, then that will go on 1 of the links and you will see the graph like this. But if you have many clients doing things, then it should usually average out to use both links about equally (with each gateway weight 1, like you have).
    The general pass rule on every LANn needs to specify gateway MultiWAN. Maybe there are some rules on your LAN/s that are matching traffic but not specifying gateway MultiWAN?

  • The thing is that i have many users behind routers (without nat)
    My LAN rules looks like this (att)
    subnets_inf - aliases with my networks subnets, the rest are single rule-row for each alias - client

    Have You any idea ?

    ![PFSense multiWAN 05.png](/public/imported_attachments/1/PFSense multiWAN 05.png)
    ![PFSense multiWAN 05.png_thumb](/public/imported_attachments/1/PFSense multiWAN 05.png_thumb)

  • On those rules for the individuals to any - "beep", "AdamekIrena"… - you need to have gateway MultiWAN selected (in the advanced section of the rule page) - that will show in the Gateway column. I can't see that in the screen shot because the alias popup box is covering it.

  • Yes, I have it
    For every single rule - gateway as multiwan and in/out pointed…

  • That should work - but I haven't really looked hard on my systems to see if a limiter (In/Out) and load-balanced gateway group works together as it should. (The devices I have on limiters are in failover gateway groups, so they only get fed to 1 gateway at a time.) I will try the load-balanced gateway  limiter combination at work tomorrow.
    You could see if the limiter is causing a problem - take the limiter off a rule and see if the corresponding subnet starts to load-balance.
    Can anyone else confirm if this combination works for them?

  • ..when I unCheck 'use sticky connections' both WANs are used and the transfer is about 50/50… so it is good, but i have to use 'sticky connections to not let to drop https connections /or  is there any other way ?