[Gelöst] VDSL mit O² funktioniert nicht / Brauche hilfe beim Einrichten.



  • Hallo,
    wir verwenden einen ganzen Haufen pfSense auf der Hardwarebasis von Soekris 6501 um über VPN unsere Standorte zu verbinden. Soweit so gut.
    Normalerweise nutzen wir als ISP Kabeldeutschland. (Ist halt günstig und schnell.)

    Jetzt konnten wir an einem Standort kein Kabeldeutschland bekommen, daher haben wir O² VDSL gebucht.
    Diese "tolle" o² Box 6431 kann nur "PPPoe pass through". Leider kann man die Box nicht einstellen, dass sie nur als Modem oder Bridge dient.

    Ich habe also ein wenig Google benutzt und herrausgefunden, dass in dieser Konstellation ein VLAN eigerichtet werden muss. Nun findet man im Internet verschiedene Aussagen darüber welche VLAN-ID eingestellt werden muss. Ich konnte 7, 11 und 12 in verschiedenen Anleitungen finden. Leider funktioniert keine der vorgenannten.

    Die Hotline bietet hierzu leider keine Hilfe. Habe nur die Info bekommen MTU= 1429, VPI/VCI = 1/32, Auth über CHAP, Login und PW finde ich im Willkommensschreiben. IP und DNS werden automatisch zugeteilt bei der Einwahl.

    Ich habe dann bei dem lokalen Hardwaredealer ein VDSL-Modem  ALLNET ALL126AS2 erstanden. Dieses bekommt zwar einen Link und zeigt im Interface auch die selbe Datenrate wie die Box an aber ich kann keine Verbindung aufbauen.

    In den Systemlogs- PPP findet sich folgendes:

    Nov 24 21:15:01 ppp: [wan_link0] Link: reconnection attempt 7980 
    Nov 24 21:15:01 ppp: [wan_link0] PPPoE: Connecting to '' 
    Nov 24 21:15:10 ppp: [wan_link0] PPPoE connection timeout after 9 seconds 
    Nov 24 21:15:10 ppp: [wan_link0] Link: DOWN event 
    Nov 24 21:15:10 ppp: [wan_link0] LCP: Down event 
    Nov 24 21:15:10 ppp: [wan_link0] Link: reconnection attempt 7981 in 3 seconds 
    Nov 24 21:15:13 ppp: [wan_link0] Link: reconnection attempt 7981 
    Nov 24 21:15:13 ppp: [wan_link0] PPPoE: Connecting to '' 
    Nov 24 21:15:22 ppp: [wan_link0] PPPoE connection timeout after 9 seconds 
    Nov 24 21:15:22 ppp: [wan_link0] Link: DOWN event 
    Nov 24 21:15:22 ppp: [wan_link0] LCP: Down event 
    Nov 24 21:15:22 ppp: [wan_link0] Link: reconnection attempt 7982 in 4 seconds 
    
    

    Was mich ein wenig stutzig macht, ist dass die Statusanzeige der Interfaces keine MAC adress anzeigt und die Uptimer immer auf Null steht und anscheinend eine Verbindung Connect hat.

    Hat hier evtl. jmd. erfahrungen mit VDSL allgemein oder speziell mit O² und kann mir sagen worauf ich achten muss?

    Ich bin für Tips sehr dankbar!



  • Wenn ich alles Richtig verstanden habe.
    Dann:
    Lass doch die Einwahl vom Router durchführen und pack die Sense dahinter und gib der Sense eine lokale IP als WAN.


  • Moderator

    @dkst: Ich glaube loki hatte nichts von UMTS oder LTE erwähnt oder irre ich mich? Du hast zwar recht, dass das ein ziemlich übles Unterfangen wäre mit doppelter NAT, UMTS und VPN, aber ich lese nur VDSL. Sobald loki VDSL sauber auf entweder der pfSense oder einem Router davor mit durchreichen an die Sense aufgebaut hat, sollte VPN - auch mit dynamischer IP - kein großes Problem sein. Zumindest was OpenVPN angeht.

    Grüße



  • Hallo,

    im deutschsprachigen Forum gabs es shcon diverse Threads bzgl. VDSL und verschiedenen VLANs. Soweit ich weiss, werden diese VLANs nur genutzt, um Dienste Wie Telefonie und IPTV etc. voneinander zu trennen und zu Priorisieren. Jetzt weiss ich nicht, wie es bei O2 ist - brauchst du da evtl. gar keine VLANs zu konfigurieren?

    Ggfl. musst/kannst du auch einen anderen Port am Modem wählen - wenn verfügbar.

    Falls das alles nicht geht, würde ich dir einen alternative Router empfehlen, evtl. eine FritzBox, diese die Einwahl übernehmen lassen und dann die pfsense an einen LAN Port der FritzBox anschließen. An der FritzBox kannst du dann "Exposed Host" einrichten, das ist deine pfsense und diese bekommt dann sämtliche Ports 1 zu 1 weitergeleitet.

    Alle Weiteren Einstellungen, Firewall, VPN kannst du wie gehabt und ohne Zusatzaufwand konfigurieren. Ich nutze diese "Doppel-NAT" mit 3 ADSL Anschlüssen und FritzBoxen so.

    PS:
    Wenn du diese Einstellung so vornimmst, prüfe bitte, dass du auf deiner pfsense WAN Schnittstelle keine privaten IP-Adressen blockst, denn du brauchst ja die Kommunikation von FritzBox und pfsense.



  • Ja habe meinen Fehler kurz nach dem erstellen bemerkt.
    Sollte aber doch gelöscht sein der Teil.


  • Moderator

    @dkst dafür finde ich den "durchstreichen" Tag sinnvoll(er), dann weiß man noch worauf sich die anderen Kommentare beziehen ;)



  • Hallo ,
    als erstes mal vielen Dank für eure Antworten und entschuldigt bitte meine späte Antwort.

    Der Witz an der Geschicht ist: Das Problem hat sich gelöst. Am Montag habe ich nochmal verschiedene Einstellugen geprüft und nix hat funktioniert. Dachte ich.
    2 Stunden später hat ein Kollege mit einem Techniker bei O² telefoniert und der fragt wo unser Problem sei es funktioniert doch alles. Als ich mich dan im System angemeldet habe war tatsächlich alles i.O.

    Nun die Einstellungen:
    Infos kommen aus folgendem Artikel: http://www.heise.de/netze/artikel/pfSense-als-VDSL-Router-221500.html

    Nur das VLAN muss ID 11 sein.