How do I port forward quake 3?



  • Hello guy's. Right now I have my gaming server running. I couldn't get it online with pfsense because I don't know how to do port forwarding. How I had it setup was.        Cable Modem –---- > PFSENSE -------- > Netgear WNDR4500  Wifi Router  -------> TP-LINK TL-SG1016 16 port Gigabit Switch ------------- > Have connected media player, Gaming server, VOIP

    But couldn't get it to work with PF Sense so I connect my cable modem directly to my router. Here are a pic of the ports I forward. There is a main website with information of port forwarding so I went by with it. Here is ports of what my router is set for my gaming server. So how do I get my pfsense to forward these ports like my router? Ty

    ![got my quake 3 server up and runing with these port forwarding.png](/public/imported_attachments/1/got my quake 3 server up and runing with these port forwarding.png)
    ![got my quake 3 server up and runing with these port forwarding.png_thumb](/public/imported_attachments/1/got my quake 3 server up and runing with these port forwarding.png_thumb)



  • Here is a port forwarding article from the wiki -> https://doc.pfsense.org/index.php/How_can_I_forward_ports_with_pfSense%3F

    Here is the short answer…. From the admin page,  goto Firewall -> NAT



  • @marvosa:

    Here is a port forwarding article from the wiki -> https://doc.pfsense.org/index.php/How_can_I_forward_ports_with_pfSense%3F

    Here is the short answer…. From the admin page,  goto Firewall -> NAT

    Am I doing something wrong? I can't get it to connect to my quake 3 server also not showing up on qtracker.

    ![nat port forward.png](/public/imported_attachments/1/nat port forward.png)
    ![nat port forward.png_thumb](/public/imported_attachments/1/nat port forward.png_thumb)



  • And edit

    ![nat edit.png](/public/imported_attachments/1/nat edit.png)
    ![nat edit.png_thumb](/public/imported_attachments/1/nat edit.png_thumb)



  • Well, what have you done with your network since you installed PFsense?  In your old router, you were forwarding ports to 10.0.0.5, but in PFsense you are forwarding to 192.168.1.7.  What is your current LAN?

    I just looked at your network map, it probably wasn't working because you were double NAT'ing and either forgot to port forward on one of the devices or were forwarding to the wrong IP on one of them.

    This what I would do….  decide on a LAN IP scheme (e.g. 10.0.0.0/24), log into your netgear and remove the port forwarding rules, disable DHCP and assign your netgear an IP in the range you decided on.

    After that, connect your network as shown below:

    Cable Modem -> PFsense -> Switch -> Servers, PC's and other devices
                                                      |
                                                      -------> Netgear Wifi Router (verify forwarding rules are removed, DHCP is disabled and plug into
                                                                                                  a LAN port, this device is now functioning as a layer 2 access point)

    Once configured as above, enable DHCP on PFsense and verify that anything statically configured has an IP in the new range and has PFsense as the default gateway.

    Re-do your port forwards on PFsense according to your new IP scheme and everything should work.

    This is exactly how I have my network set up and it works perfectly.



  • @marvosa:

    Well, what have you done with your network since you installed PFsense?  In your old router, you were forwarding ports to 10.0.0.5, but in PFsense you are forwarding to 192.168.1.7.  What is your current LAN?

    I just looked at your network map, it probably wasn't working because you were double NAT'ing and either forgot to port forward on one of the devices or were forwarding to the wrong IP on one of them.

    This what I would do….  decide on a LAN IP scheme (e.g. 10.0.0.0/24), log into your netgear and remove the port forwarding rules, disable DHCP and assign your netgear an IP in the range you decided on.

    After that, connect your network as shown below:

    Cable Modem -> PFsense -> Switch -> Servers, PC's and other devices
                                                      |
                                                      -------> Netgear Wifi Router (verify forwarding rules are removed, DHCP is disabled and plug into
                                                                                                  a LAN port, this device is now functioning as a layer 2 access point)

    Once configured as above, enable DHCP on PFsense and verify that anything statically configured has an IP in the new range and has PFsense as the default gateway.

    Re-do your port forwards on PFsense according to your new IP scheme and everything should work.

    This is exactly how I have my network set up and it works perfectly.

    Well I installed M0n0wall. Yesturday the lease ended. PFsense wouldn't renew it. I had hours with issue I reset my router, my router was setup as ap anyways i set it back and then ask for ip from my modem it started working. I heart pfsense wouldn't renewal by asking modem for ip. How I have set like before. Modem connected to pfsense, pfsense  to switch, router and rest of computer to switch I only got 2 wireless to my router. Right now its set as ap. Can you please do a 1, 2, 3 steps. Oh my 2 server is setup i 192.168.# I dunno how to set my router. I'm very new to this. Sir do you have comcast?



  • I heart pfsense wouldn't renewal by asking modem for ip.

    When you switch edge devices like that…. you typically have to power cycle your cable modem before it'll grab an IP.

    Modem connected to pfsense, pfsense  to switch, router and rest of computer to switch I only got 2 wireless to my router.

    Does this mean you have your network configure like my previous post?

    Oh my 2 server is setup i 192.168.#

    Ok, well they need to be in whatever LAN scope you decided on, so is 192.168.1.0/24 what you decided on?  If not, your servers will need to be changed.

    I dunno how to set my router.

    I'm somewhat confused… You were able to configure you're port forwards, so you know a fair amount.  All you have to do is log in and disable DHCP (is this what you need help with?).  Then make sure the cable coming from the switch is plugged into a LAN (not WAN) port

    Can you please do a 1, 2, 3 steps

    sure, on which part?

    Sir do you have comcast?

    No, I have Charter.  Why do you ask?



  • @marvosa:

    I heart pfsense wouldn't renewal by asking modem for ip.

    When you switch edge devices like that…. you typically have to power cycle your cable modem before it'll grab an IP.

    Modem connected to pfsense, pfsense  to switch, router and rest of computer to switch I only got 2 wireless to my router.

    Does this mean you have your network configure like my previous post?

    Oh my 2 server is setup i 192.168.#

    Ok, well they need to be in whatever LAN scope you decided on, so is 192.168.1.0/24 what you decided on?  If not, your servers will need to be changed.

    I dunno how to set my router.

    I'm somewhat confused… You were able to configure you're port forwards, so you know a fair amount.  All you have to do is log in and disable DHCP (is this what you need help with?).  Then make sure the cable coming from the switch is plugged into a LAN (not WAN) port

    Can you please do a 1, 2, 3 steps

    sure, on which part?

    Sir do you have comcast?

    No, I have Charter.  Why do you ask?

    Hello. Well here is the ip of my servers.

    Pe 1850  192.168.1.2

    Pe 2600 192.168.1.3

    NSA325 192.168.1.4

    Netgear turned off DHCP Server set on ip 192.168.1.9

    Firewall set on 192.168.1.1

    I have wd live tv, vonage voip,  two laptop with no static ip. I did a comcast speed test and ping is higher and taking long to start download. Facebook taking long time to start. I did ap on it and works just i couldn't access to my router ap. Hard to configure static. It's frustrated. I do want to get the my netgear going and use the interface of that show me ip of client and so on. This frustration. By the way I got my netgear forward ports through a portforarding website that tell u what ports to forward of specific game and program. I've been in computer business since the 90's but weakest point is networking. And I want to streghten my skills. Here is how I setup my netgear. Ty Sr. Please be paitence with me and work with me in steps.

    ![how i setup 2.jpg](/public/imported_attachments/1/how i setup 2.jpg)
    ![how i setup 2.jpg_thumb](/public/imported_attachments/1/how i setup 2.jpg_thumb)



  • Well I got it working like this way. I can now access my router configure as ap with ip i setup. DNS I got it from my firewall m0n0wall. Ping is back to normal when doing a speed test at comcast speed test page. Download speed is back to normal. Sorry couldn't do the other way. Would this work? M0n0wall will tranfer back to pfsense soon. What a headach networking is.

    ![got it working in ap mode this way i reset it router server to wan of netgear 2.jpg](/public/imported_attachments/1/got it working in ap mode this way i reset it router server to wan of netgear 2.jpg)
    ![got it working in ap mode this way i reset it router server to wan of netgear 2.jpg_thumb](/public/imported_attachments/1/got it working in ap mode this way i reset it router server to wan of netgear 2.jpg_thumb)



  • @marvosa:

    Here is a port forwarding article from the wiki -> https://doc.pfsense.org/index.php/How_can_I_forward_ports_with_pfSense%3F

    Here is the short answer…. From the admin page,  goto Firewall -> NAT

    Hi so I got everything figure out of setting my router static and so forth. Can you help me with step by step. That link is confusing and I tried it before. The ip of the server is 192.168.1.2. TY



  • Sorry for the delay, I was on vacation.  Do you still need help?



  • @marvosa:

    Sorry for the delay, I was on vacation.  Do you still need help?

    Yup been busy here to but I want to still setup can you help with easy steps?


Log in to reply