Vmware tools not loading on reboot 2.1 esxi - workaround / fix / solved



  • [popular search terms in subject for future google searches]

    after following some of the guides for installing vmware tools on my pfsense 2.1 esxi 5.1 firewall, I still had a problem of vmware tools starting just fine on the first boot. but after that, vmware tools would not load unless i did a vmware-tools reinstall.

    well, i found out that for some reason when vmware-tools start, it makes a file called "not_configured" in /etc/vmware-tools which means you have to reinstall vmware tools upon every boot.

    a workaround is to delete the file before each reboot OR before vmware-tools attempts to start.

    if you edit this file:  "/usr/local/etc/rc.d/vmware-tools.sh" and  insert this line at the TOP of the file:  "rm /etc/vmware-tools/not_configured" then vmware-tools will delete the not_configured file when the startup script runs, and everything will work as expected.

    theres probably some other way of doing this… but this workaround solved my problem.

    guide for installing vmware tools: http://www.v-front.de/2013/06/how-to-install-or-update-vmware-tools.html


  • Rebel Alliance Global Moderator

    So not having the issue with tools showing running, or starting - but did have issue with esxi 5.5 saying running, but for version where it use to say 3rd party, it says not installed ;)

    So on the bottom of that linked install guide is a comment how to fix it

    I also experienced this strange behavior after upgrading to ESXi 5.5.
    I could fix it with the following steps:
    1. Choose "Install VMware Tools" from the VM's console menu
    2. Wait a few seconds, then choose "End VMware Tools install".
    3. Wait a few seconds, refresh the VM view, and the status might eventuell change to "Installed".

    Now show correct in the client, just need to check vserver