Squid dejo de funcionar



  • Estimado buenas, ac un tiempo me paso lo mismo y nunca supe que paso y hoy tengo instalado la vercion 2.1-RELEASE (amd64) FreeBSD 8.3-RELEASE-p11 y me genera el mismo problema.

    comento

    todo bien configurado el squid y squidGuard y todo funcionando pero llega un minuto donde se cae y no filtra nada lo reinicio y nada.

    gracias





  • Gracias por tu tiempo pero Pensé en lo mismo pero el problema es el siguiente, algo encontré.

    2013-11-29 17:05:38 [54527] squidGuard 1.4 started (1385755538.696)
    2013-11-29 17:05:38 [54527] squidGuard ready for requests (1385755538.697)
    2013-11-29 17:05:56 [53727] Warning: Possible bypass attempt. Found multiple slashes where only one is expected: http://images.lun.com/luncontents/Archivos video audio del accesorio/2013/nov/29//
    2013-11-29 17:05:56 [53727] Warning: Possible bypass attempt. Found multiple slashes where only one is expected: http://images.lun.com/luncontents/Archivos video audio del accesorio/2013/nov/29//AVISO_HOME_PARIS_PARADE_CLEMP.flv
    2013-11-29 17:09:45 [53727] squidGuard stopped (1385755785.089)
    2013-11-29 17:09:45 [53778] squidGuard stopped (1385755785.089)
    2013-11-29 17:09:45 [54056] squidGuard stopped (1385755785.090)
    2013-11-29 17:09:45 [54310] squidGuard stopped (1385755785.090)
    2013-11-29 17:09:45 [54527] squidGuard stopped (1385755785.090)

    para empezar el squidGuard  no está iniciado cada vez que lo reinicio o inicio me topa con el mismo error que muestro más arriba, creo que la solución es borra la cache pero no se donde.



  • NO se si tu problema es el cache…
    Pero sii quieres borrarlo...

    1)squid -k shutdown

    2)rm -fR /var/squid/cache/*

    3)squid -z



  • @cdiaz:

    Gracias por tu tiempo pero Pensé en lo mismo pero el problema es el siguiente, algo encontré.

    2013-11-29 17:05:38 [54527] squidGuard 1.4 started (1385755538.696)
    2013-11-29 17:05:38 [54527] squidGuard ready for requests (1385755538.697)
    2013-11-29 17:05:56 [53727] Warning: Possible bypass attempt. Found multiple slashes where only one is expected: http://images.lun.com/luncontents/Archivos video audio del accesorio/2013/nov/29//
    2013-11-29 17:05:56 [53727] Warning: Possible bypass attempt. Found multiple slashes where only one is expected: http://images.lun.com/luncontents/Archivos video audio del accesorio/2013/nov/29//AVISO_HOME_PARIS_PARADE_CLEMP.flv
    2013-11-29 17:09:45 [53727] squidGuard stopped (1385755785.089)
    2013-11-29 17:09:45 [53778] squidGuard stopped (1385755785.089)
    2013-11-29 17:09:45 [54056] squidGuard stopped (1385755785.090)
    2013-11-29 17:09:45 [54310] squidGuard stopped (1385755785.090)
    2013-11-29 17:09:45 [54527] squidGuard stopped (1385755785.090)

    para empezar el squidGuard  no está iniciado cada vez que lo reinicio o inicio me topa con el mismo error que muestro más arriba, creo que la solución es borra la cache pero no se donde.

    Se puede apreciar que (en prinicipio) el paro no es por reglas o problemas en squidGuard. Seguramente es squid. Si se para squid, se para squidGuard. Revisa log de squid. Prueba borrando la caché de squid, como te dijeron.