Nerd in need - OpenVPN add route errors?

  • Hi there,

    First of all I'd like to thank all those community members whose time and effort has gone into building and maintaining this excellent distro. I've been using pfSense for nearly a year now, and I love the flexibility it offers, allowing me to perform enterprise routing and ASA tasks quickly and cheaply using standard COTS kit. Keep up the good work!  :D

    I'm writing this post as I've come up against some oVPN issues that I can't seem to figure out. - I'm a single-homed SOHO user and I've finally chopped out my old ADSL connection for a local WISP. For security reasons I thought I'd encrypt all of my traffic over the WISP's network, using ProXPN's 512-bit service.

    Here are the ProXPN suggested settings:

    Here are the settings applied to my box:

    My ISP’s default GW is:
    My IP is: {–omitted for privacy--}

    Having configured my box to establish a connection and authenticate with the VPN server, the local openVPN service seems to receive pushed options, but then it appears to add an incorrect value to the routing table [see error logs]:

    Appending the [route;] command to advanced config gives me these results:
    i.e. the process seems to delete the correct routes and exits with an error: [ERROR: FreeBSD route add command failed: external program exited with error status: 1]

    Removing the quad zero route from the advanced config, seems to resolve the error – presumably as it is using the pushed redirect-gateway option from the server. However, there is still no connectivity from the box. I’m wondering if it has something to do with this route: [/sbin/ifconfig ovpnc2 mtu 1500 netmask up] – as why is it defining the pushed host address as BOTH the host address AND the gateway??

    I’m a bit stumped by this, and can only conclude that the reason the route is erased is due to the fact that the new gateway address is unreachable, after one of the route modifications has been made.

    If anyone has any suggestions on how to fix this issue, your help would be greatly appreciated!


  • I've fixed the issue by removing the following from my VPN provider's config:

    [route-delay 1 10;] [route-metric 512]
    [route-method exe]

    Also, removing the quad zero route from the config, prevented the add route error as my VPN provider was pushing the [redirect-gateway] option anyway.

Log in to reply