[Solucionado] Configuracion portal cautivo



  • Tengo un problema con la configuración de un portal cautivo:

    Cómo le tengo que hacer para que inalambricamente me pueda conectar por medio de un tp-link.
    De mi LAN tengo dhcp 10.10.10.50 a la 10.10.10.100. y de esa lan le conecte un switch y si conecto una computadora alambricamente si pude entrar al portal cautivo, pero si a un puerto del switch le conecto un router tp-link directo a la WAN de el mismo no me puedo conectar al portal. Me podrían ayudar en eso?



  • Eso es que el enrutador inalámbrico no debe actuar conforme a lo necesario. Desactiva su servidor DHCP.

    Prueba primero la instalación sin portal cautivo (desactivándolo).



  • Ya lo intente y sigo sin su objetivo de poder accesar.



  • ¿que intentaste exactamente?, podrías poner como tienes configurado el portal, como tienes configuradorado el router, no veo porque tengas que tener problemas.



  • Por medio de mi pc donde tengo instalado el pfsense, a mi interface lan le tengo configurado para que me de dhcp 10.10.10.50 -100.
    al portal cautivo le inserte un index.php para que se logen los usuarios. Y por medio de mi lan conecte un patchcord a un switch y del switch otro patchcord a otra pc, y si me da dhcp a esa pc y cuando abro el navegador si me manda al portal para que ingresen su usuario o contraseña, y si me sale exitoso al ingresar los datos. Pero cuando del mismo switch conecto otro pachtcord mas a un router tp-link a la WAN de el, al momento de conectarme con una laptop, celular o cualquier dispositivo inalambricamente, abro el navegador en cualquiera de ellos y no me redirecciona al portal, pero la pc que esta conectada al switch si me da el acceso al portal.



  • ¿Se le asigna ip al ordenador conectado vía wifi (Tp-Link)?

    Postea salida del comando ipconfig, si es Windpws. ifconfig si no es Windows.



  • Para esta claro que el problema esta en tu AP; aunque este asignara IP, a la hora de tomar salida, pasaría por el portar, yo lo pruebo a cada rato, conectas un router, este da salida, y pasan por el portal todos sus usuarios, solo que estos me aparecen todos con la misma mac.

    Creo que tu ap, router o lo que sea, no esta tomando IP, por lo tanto no tiene salida, debes configurarlo para que toma o bien la ip que le da el pfsense, o bien, para que tenga ip estática y tenga salida, debes configurar la puerta de entrada y todo eso, pero eso ya es bronca del router :D



  • Muchas gracias bellera y zac. Ya pude concluir con eso, y si era mi AP?



  • Hasta donde yo se de portal cautivo no puedes hacerlo funcionar detras de un roother, necesitas poner un Access Point, ya que todos los que se conecten al routher saldran con la misma direccion de routher y con solo validar un usuario, podrán navegar todos los usuarios conectados a un routher… :)  a mi me paso algo parecido con los permisos de navegacion de el Proxy filter, que al dar de alta la direccion mac del routher, todos los usuarios que se conectaban a el tenian los mismos permisos!! :p... :D



  • Varias personas me dijeron lo mismo, pero si me logro funcionar. Todos los dispositivos se pudieron conectar y logear. Gracias por el aporte.


Log in to reply