Squid proxy cache not working



  • Hi,im trying to setup cache server for 2 weeks but it is not working for me,if i activate the Transparent Proxy mode only a few site is working.I have to change something in my firefox to?



  • Are you using squid2 or squid3?
    If squid3 then active "DNS IPv4 first".

    If you are using "Tranparent" mode then it will only filter port 80 which is http and you do not need to change anything in your webbrowser.

    Please give more information about what packages you are using, which pfsense version



  • i am using squid3 on pfsense 2.1-RELEASE (amd64) , if i activate "Transparent HTTP proxy" and "Resolv dns v4 first" only the https websites are working, example https://www.google.com/ but http://www.youtube.com/ is not woking.




  • Your screenshot shos that you DO NOT have transparent proxy enabled. This means you have to put the proxy ettings into your webbrowser.

    Do you allow connections to your squid proxy in your LAN firewall rules? Probably best to set a rule which first allows "any to any" to make sure squid is working.



  • @Nachtfalke:

    Your screenshot shos that you DO NOT have transparent proxy enabled. This means you have to put the proxy ettings into your webbrowser.

    if i activate "Transparent HTTP proxy" and "Resolv dns v4 first" only the https websites are working, i did not add any rules to my firewall.



  • i made a new LAN rule any to any and activated the "Transparent HTTP proxy" but i get this message back from the websites : "The connection has timed out"




  • Try to enable "Allow IPv6" on System - Advanced. Even if you do not use IPv6 it should be enabled - if I remember correct - to work with squid3 which is compiled with IPv6.



  • it was active.. :(




  • what should i modify?



  • @HunorR:

    what should i modify?

    Don't know. Try with squid3-dev which uses squid 3.3.x instead of squid 3.1. Perhaps this fixes something.