Trying to get RNX-N600UBE working in 2.1-release



  • Hello!

    Someone gave me a Rosewill RNX-N600UBE and I wanted to see if it could work as an AP in pfsense 2.1-release (i386). So far, I have not been able to get the unit to show up as an available interface in the pfsense web UI, or with ifconfig -a.

    Can someone help me figure out why it is not working? Maybe I missed a step somewhere?

    So far, I have:

    1. Plugged the Rosewill RNX-N600UBE directly into the motherboard's USB connector
    2. Added these two lines to /boot/loader.conf.local:
      if_run_load="YES"
      runfw_load="YES"
    3. Rebooted

    According to official pfsense documentation, the chipset this adapter uses, the Ralink RT3572, IS supported:

    Additional information with the device connected to the pfsense box:

    
    $ pciconf -lv
    
    hostb0@pci0:0:0:0:	class=0x060000 card=0x0d7c105b chip=0x0bf58086 rev=0x03 hdr=0x00
        class      = bridge
        subclass   = HOST-PCI
    vgapci0@pci0:0:2:0:	class=0x030000 card=0x0d7c105b chip=0x0be18086 rev=0x09 hdr=0x00
        class      = display
        subclass   = VGA
    pcib1@pci0:0:28:0:	class=0x060400 card=0x0d7c105b chip=0x27d08086 rev=0x02 hdr=0x01
        class      = bridge
        subclass   = PCI-PCI
    pcib2@pci0:0:28:1:	class=0x060400 card=0x0d7c105b chip=0x27d28086 rev=0x02 hdr=0x01
        class      = bridge
        subclass   = PCI-PCI
    uhci0@pci0:0:29:0:	class=0x0c0300 card=0x0d7c105b chip=0x27c88086 rev=0x02 hdr=0x00
        class      = serial bus
        subclass   = USB
    uhci1@pci0:0:29:1:	class=0x0c0300 card=0x0d7c105b chip=0x27c98086 rev=0x02 hdr=0x00
        class      = serial bus
        subclass   = USB
    uhci2@pci0:0:29:2:	class=0x0c0300 card=0x0d7c105b chip=0x27ca8086 rev=0x02 hdr=0x00
        class      = serial bus
        subclass   = USB
    uhci3@pci0:0:29:3:	class=0x0c0300 card=0x0d7c105b chip=0x27cb8086 rev=0x02 hdr=0x00
        class      = serial bus
        subclass   = USB
    ehci0@pci0:0:29:7:	class=0x0c0320 card=0x0d7c105b chip=0x27cc8086 rev=0x02 hdr=0x00
        class      = serial bus
        subclass   = USB
    pcib3@pci0:0:30:0:	class=0x060401 card=0x0d7c105b chip=0x24488086 rev=0xe2 hdr=0x01
        class      = bridge
        subclass   = PCI-PCI
    isab0@pci0:0:31:0:	class=0x060100 card=0x0d7c105b chip=0x27bc8086 rev=0x02 hdr=0x00
        class      = bridge
        subclass   = PCI-ISA
    atapci0@pci0:0:31:2:	class=0x01018f card=0x0d7c105b chip=0x27c08086 rev=0x02 hdr=0x00
        class      = mass storage
        subclass   = ATA
    none0@pci0:0:31:3:	class=0x0c0500 card=0x0d7c105b chip=0x27da8086 rev=0x02 hdr=0x00
        class      = serial bus
        subclass   = SMBus
    re0@pci0:2:0:0:	class=0x020000 card=0x0d7c105b chip=0x816810ec rev=0x06 hdr=0x00
        class      = network
        subclass   = ethernet
    em0@pci0:3:0:0:	class=0x020000 card=0x13768086 chip=0x107c8086 rev=0x05 hdr=0x00
        class      = network
        subclass   = ethernet
    
    

    And…

    
    $ usbconfig dump_device_desc
    
    ugen4.2: <802.11 n WLAN Ralink> at usbus4, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON
    
      bLength = 0x0012 
      bDescriptorType = 0x0001 
      bcdUSB = 0x0200 
      bDeviceClass = 0x0000 
      bDeviceSubClass = 0x0000 
      bDeviceProtocol = 0x0000 
      bMaxPacketSize0 = 0x0040 
      idVendor = 0x148f 
      idProduct = 0x5572 
      bcdDevice = 0x0101 
      iManufacturer = 0x0001  <ralink>iProduct = 0x0002  <802.11 n WLAN>
      iSerialNumber = 0x0003  <1.0>
      bNumConfigurations = 0x0001</ralink> 
    

    What should I try next?



  • Relevant…. http://forums.freebsd.org/viewtopic.php?f=34&t=7562&start=300

    Seems like there's some good information there but I haven't finished trying to understand how I can apply it to this situation. :)



  • Does anyone have some ideas to try?

    I'm starting to assume pfsense 2.1 has too many bugs for wireless to work, and therefore I'll just stick with using a separate AP.



  • Hello! I just performed a fresh install of 2.1.3 and tried this all again but still no luck - under the Wireless tab in webconfig, I'm not able to select it as a device.

    Can anyone lend a hand with this, please? :)



  • What happens when you do the following?

    First, the wireless card must be assigned as an OPT interface and enabled before the remaining configuration can be completed. You need to navigate to Interfaces -> OPTn to begin configuration.

    http://pfsensesetup.com/wireless-access-point-configuration-in-pfsense/



  • Hello! Those steps are a bit out of date. The interface has changed, and there is no longer a "Interfaces -> OPTn" option in the UI. There is now an Interfaces > Assign option.

    There is now this section for assigning a wireless interface:

    Have been trying for the past several days to get this to work, but am not having any luck with the wireless adapter showing up here:

    Sad… :(



  • Will you provide a print screen of the Interface Assignment tab? I assure you that the steps in the docs are applicable to 2.1.3 .


Log in to reply