How to open port 6879



  • How do I open port 6879 so i can use my torrent client??



  • http://forum.pfsense.org/index.php?action=search

    create a NAT forwarding.
    Alternatively (probably better for you) activate upnp and let your BT client handle the portforwarding.



  • Sorry I ment to get a little more detail. like wat would the NAT rule loook like cus how i'm doin it its not working

    Thanks



  • Well when you already configured it and it does not work how about you post what you did?
    Screenshots of your rules?



  • Here are the Screenshots, Sorry this is my first attempt at firewall rules and NAT.

    Thanks

    ![Firewall Rule.JPG](/public/imported_attachments/1/Firewall Rule.JPG)
    ![Firewall Rule.JPG_thumb](/public/imported_attachments/1/Firewall Rule.JPG_thumb)
    ![NAT Rule.JPG](/public/imported_attachments/1/NAT Rule.JPG)
    ![NAT Rule.JPG_thumb](/public/imported_attachments/1/NAT Rule.JPG_thumb)



  • The rules look good.
    How exactly does the "it does not work" behave?
    What does not work?
    Are inbound connections not possible?
    What client are you using?



  • Sorry pfSense 1.2RC3

    i'm using Azureus and when i test the port i get the Error message

    "Testing port 6879 …
    NAT Error - Connect attempt to 198.54.202.250:6879 (your computer) timed out after 20 seconds. This means your port is probably closed
    Proxy IP is '10.0.0.11' but this is a local address ('Forwarded-For' request header was '10.0.0.11, 41.245.137.251, 198.54.202.22')."

    tried the Upnp too but that didn't work either.

    Thanks



  • Are you behind a Proxy? Because –> Proxy IP is '10.0.0.11' but this is a local address ('Forwarded-For' request header was '10.0.0.11, 41.245.137.251, 198.54.202.22')."

    Somehow i see here multiple public IPs.
    In your rule-screenshots your public IP is 41.245.137.251
    But the NAT-test was made on 198.54.202.22
    I think you have a more complex setup than just: WAN - pfSense - LAN
    Could you provide more information?



  • Tram, your computer is 10.0.0.11 and your pfSense is 10.0.0.1, right?
    NAT and rules have to point to the PC with the client software, not the router itself.



  • It is a WAN - pfsense - LAN Setup

    no other complications.
    198.54.202.22 is the IP that i'm trying to connect to, it is not my WAN IP 41.245.137.251
    The IP 10.0.0.11 is the static IP which is assigned to My PC by the DHCP on pfSense

    So
    LAN 10.0.0.11, WAN 41.245.137.251, External IP I'm trying to connect to 198.54.202.22

    Needs to be open inbound and outbound traffic

    does that help??

    I did notice that i changed it to 10.0.0.11 but still fails



  • ah now i see.
    in your NAT-rule your destination for the forwarding is 10.0.0.1. That means you forward the port to the LAN IP of your pfSense.
    There has to be 10.0.0.11 (if that is the IP of your Computer on which Azureus is running)
    If you change the rule after the initial creation you have to change the corresponding firewall rule too.



  • Ok both NAT and firewall rules have been changed they no use 10.0.0.11 But still the same error message.



  • Ok my uploading is working there is no problem there how ever it still says there is a NAT problem on my download side. can any one help me with this??



  • Azureus works fine with UPnP. I use that combination all the time. Testing the port shows OK. You should try removing the port mappings and using UPnP. In Azureus check the Plugins menu -> Log Views -> UPnP. If you can't get it to work copy paste that log here, copy/paste the UPnP Status page mappings in pfSense, and provide me with the UPnP settings in pfSense.


Log in to reply