Como utilizar certificados ssl firmados en portal cautivo



  • Buenas, quiero utilizar https en la autenticacion del portal pero sin que le de error de certificado a los usuarios, para esto es necesario tener los certificados firmados, estuve probando con comodo creando los certificados y luego agregándolos a través de cert manager pero sigo con el mismo problema, seguramente en algo estoy fallando.
    Estoy utilizando la version 2.1 Release de pfsense.

    Desde ya muchas gracias





  • Muchas gracias por la respuesta, eh realizado todo lo que dice en ese post y sigo con el mismo problema de error de certificado, eh firmado un certificado en Symantec por 30 días de prueba, lo ingrese en cert manager y cree la entrada dns correspondiente como indica en la configuración de https en el portal y sigo con el mismo problema.
    Adjunto una captura de pantalla del error




  • El nombre de tu equipo tiene que coincidir con el que se introdujo para generar el certificado. Error frecuente. No sé si será esto.

    Te diría que primero pruebes con la administración web (WebGui) de pfSense. A ver si en modo https entras sin error de certificado. Esto te dirá si entidad de certificación + certificado del servidor están correctamente instalados en el Cert Manager.



  • El nombre de la maquina coincide con el que se utilizo para el certificado y tengo también creada la entrada en dns para ese nombre. No tengo configurada ninguna CA solo el certificado, adjunto captura.

    Muchas gracias




  • @bellera:

    Te diría que primero pruebes con la administración web (WebGui) de pfSense. A ver si en modo https entras sin error de certificado.

    ¿Administrando pfSense con https://hotspot.syseme.com funciona o no?

    ¿En System - General Setup Hostname es hotspot y Domain es syseme.com?



  • Gracias por tu tiempo, esta todo configurado si, empiezo a pensar que es un problema del certificado, pero quería probar con ese que es gratis antes de comprar uno. Adjunto capturas






  • ¡De nada! Eso parece, entidad desconocida por parte del navegador que usas. Actualízalo o prueba con otro (Firefox).



  • Quería agradecer por su respuesta sr. bellera, finalmente pude hacer funcionar los certificados, me estaba faltando agregar las CA del servidor.
    Aprovecho para comentar que realice todo esto de los certificados, para que el portal cautivo funcione cuando la pagina de inicio de los clientes es https.

    Saludos




  • @santi_clavijo:

    Aprovecho para comentar que realice todo esto de los certificados, para que el portal cautivo funcione cuando la pagina de inicio de los clientes es https.

    Sí, sí, ya lo tenía claro. El caso es que si funciona para el acceso a la WebGui tiene que ir también para el portal cautivo, empleando el mismo certificado. Es una manera de comprobar, sin portal cautivo de por medio.



  • Tal vez no me exprese bien el problema que tenia yo es el mismo que se comenta en este post http://forum.pfsense.org/index.php/topic,62132.msg338208.html#msg338208



  • Hola a todos quizas un poco tarde en esto de portal cautivo pero mi problema aun el mismo. Resulta que he implementado un portal cautivo en mi empresa y todo sale bien. A cada cliente le sale la ventana del portal tanto por lan como wifi. La cuestión está que con el squid en modo transparente a las paginas http navegan perfecto. El problema es a las paginas https, ya he buscado en miles de foros etc y explican lo del certificado SSL. Se lo creo pero nada. La problemática radica en que no tengo IP publica directo a internet, salgo por proxy a un servidore de una red sectorial conectada a una VPN. Es imposible que mi dns se reconosca en la red, Cuando acceso a google me sale con el SSL y no navega.



  • @santi_clavijo Buen dia clavijo..tambien stoy tratando de implementar https para el portal......y te agradeceria mucho si me das una mano...pero queria saber a q te refieres especificamente cuand dices esto: "El nombre de la maquina coincide con el que se utilizo para el certificado y tengo también creada la entrada en dns para ese nombre." principalmente. cuando aclaras esto: "y tengo también creada la entrada en dns para ese nombre." desde ya muchas gracias x todos tus comentarios.


Log in to reply