Webconfigurator GUI: 'System' pulldown blocked by 'help' for some widths



  • Using Firefox/Iceweasel on Ubuntu Saucy, maximized Monitor resolution 1200x1920:  The 'Help' item on the pfsense web configurator screen appears just below the 'System' item.  The effect is that when the cursor is located on 'System', the menu items for 'System' drop down and appear properly.  However there is no way to move the mouse past the 'help' item in a way that doesn't erase the 'system' items, instead the 'help' dropdown items appear.


  • Rebel Alliance Global Moderator

    A screenshot is of great help here.. 1200x1920??  Really you mean 1920x1200? (WUXGA)

    Maybe you have the monitor on its side? ;)



  • Clever possible diagnosis!  But, it wasn't a typo.  1200 x 1920 is in fact correct.  I think the relevant number is the width of 1200.

    Screenshot requested attached.  (I think we should expect a wider variety of screen resolutions going forward in the era of VM's and browser-equipped phones and tablets that have many new and various reported resolutions and two, four and six monitor setups)

    ![Screenshot - 12182013 - 03:59:04 PM.png](/public/imported_attachments/1/Screenshot - 12182013 - 03:59:04 PM.png)
    ![Screenshot - 12182013 - 03:59:04 PM.png_thumb](/public/imported_attachments/1/Screenshot - 12182013 - 03:59:04 PM.png_thumb)


  • Rebel Alliance Global Moderator

    that is really odd..  I have a VM that only has 1152 width resolution (1152x864).. Changed my theme to match yours, and can not get it to do that.

    Even if I make the browser window smaller it doesn't wrap the menu like that..  Try using a different theme for a work around.  I would have to look at the code - maybe there is something that doesn't like the odd resolution setting and output the page weird.

    I will have to look if I can duplicate that resolution when I get home.




  • Change the width to 1200 on the vm, then see.  The install is xubuntu saucy, all defaults on the browser.


  • Rebel Alliance Global Moderator

    I would but I don't have an option to do that ;)  Like I said you have your resolution backwards.. Why is it so long?  You have your monitor on its side or something?

    I have to assume that is what is screwing up the code of the page.




  • Thanks for your hint my resolution is backwards.  Indeed I'm typing right now on the system in question and, I double checked I counted correctly, there are exactly 1200 pixels from left to right, and there are exactly 1920 pixels up and down.  You might confirm that from the dimensions of the jpeg of the screenshot I uploaded.  And,  I'm actually looking at every one of those pixels without having to scroll or anything.  In fact the vm monitor with that resolution on native, all defaults, fresh install, xubuntu saucy works quite well in every respect so far other than the pfsense configurator.

    I'm actually displaying that vm on a multi-montior setup with greater native resolution on both X and Y.  Along with several other VM's.

    Anyhow, let's not make it about having my resolution backwards anymore.  Facebook, Youtube, google, the PFsense forum, all seem to display quite properly.  Only the pfsense webpage puts the help menu beneath the system menu then won't let me access even one of the system menu options as passing the mouse down the list causes all the options to change from the system to the help choices.  Firefox 26.0 Mozilla Firefox for ubuntu-Canonical 1.0

    Whether the page displayed is the dashboard or interfaces or any other makes no difference, the help is positioned directly below the system option.  My guess is there will be a  > which should have been a =>  or integer math that would have rounded division differently if done as floating point.



  • Rebel Alliance Global Moderator

    Do a simple test, change the resolution to standard resolution say http://en.wikipedia.org/wiki/List_of_common_resolutions

    Does that fix the problem?  I can look to a way to get my resolution to display that odd resolution.. Like I said its like wide screen monitor is on its side ;)

    Ok I rotated my screen and could set 960x1280 and still does not wrap..  Did you try a different theme?




  • Good clue for you:  I changed the default point size from the default of 17 to 16 made  the problem go away.  Changing the point size back to 17 caused the problem to return.  I don't see an option to 'change the theme'.

    Note the resolution 1200x1900 is native to the QXL driver I"m using (uploaded screenshot edited in the prior posting).

    I have to quit for today now.


  • Rebel Alliance Global Moderator

    So browser setting then..  As to theme, under general setup on the bottom there is a drop down list of themes

    So edited mine to 17 and yup broke the layout.  And I use a different theme than what you use.




  • Granted this is an old topic, its exactly what I just ran into, when I finally got around to updating.

    Having the same issue with Firefox, Looks fine in IE.

    Is there going to be a fix for this so Firefox will work by default?

    Thanks.


  • Banned

    Try deleting your entire browser cache including CSS sheets.



  • I think its now a given that the font should be changed to something more universal, but besides that one font issue, all non-font related issues seem to be fixed with a cache purge and restart of browser.  There are two separate issues going on.  One is font.  The other is cache.



  • Try this:  Install an 'out of the box' xubuntu, then make sure both the 'out of the box' Chromium (google) and Firefox browsers are loaded.  Be sure to install the 'long term support' versions likely to be favored by pfsense users.  Currently, that's 'Trusty' which will be shipped for two year.  Go to a PFsense homepage.  Log in.  See the 'System' options not be available as they are hidden by the help options.  Post a bug about it.  Notice the irony that an open source software package requires a non-free Microsoft font 'Tahoma'  to be installed by obscure technical processes before it works properly.  Have the bug be rejected.  I'm not making this up.

    It was working on Firefox using the verison before 2.15, then upon 2.15 it failed.  It might have been because I went in and hacked the menu code to fix this and my revision got deleted, I can't keep track of those details.  However, I did go and install Tahoma on the systems I care about, and I can leave this issue of 'how much do you love Tahoma and how much do you like bug reports' to other people!

    Attachment of screenshot in firefox, same as Chromium displayed, pre 'install this, download the cab with tahoma, copy the tahoma font, update the fonts' hack-fest on each of the affected systems.




  • I don't think "Re-install your computer to accommodate a pfsense anonymously that will probably get corrected in 3 days" is the best advice.  I'd wait a few days.



  • You are of course correct.  I mention this as the bug I filed on the topic was rejected within moments of having been posted yesterday, so I had no expectation anything was going to be done.  Notice also this forum discussion has been around awhile, and I got an update about it today.  So I got a little frustrated by the experience.  I wasn't so happy having to learn how to download and deploy a Microsoft font in order to access pfsense's gui.  Anyhow I do appreciate pfsense quite a lot, and hate to see this little cosmetic things be an actual barrier to deployment.

    Apologies all 'round.  Have a good weekend!



  • I just upgraded my pfsense to 2.1.5-RELEASE (i386). But I found 2 dropdown menus are overlapping, making it hard to access. Is there any chance to fix it on our own?

    I'm using 3 browsers, Chrome, Chromium, and FireFox, all give me same result, overlapping



  • Netgate Administrator

    Just for reference I'm running Xubuntu 14.04 with Firefox 31 on several systems and I've not done anything to add fonts. On each system I simply had to refresh the page to get the help menu back where it should be.

    640x480 should be enough for anybody.  ;)

    Steve



  • In order to get pfsense to work, you've got to, on every non microsoft system running a screen larger than they had in 1985, install a compatibility package, and then download a CAB file, extract it's contents, copy a file to the right directory, then rebuild the fonts.  Some details here, but I did it manually and not using the script.

    http://ubuntuforums.org/archive/index.php/t-1459709.html

    This is a bug pfsense has on both chromium and firefox.  Really I don't think it's font related, I think it's a bug in the stylesheet since the correct thing to do if the font doesn't fit is to extend the image to the right and not create another column.

    But, hey, good luck.  Try filing a bug report, maybe yours won't get killed like mine did.


  • Banned

    Couldnt agree more!


  • Banned

    Not to mention: there are hundreds of free, opensource fonts, available from https://www.google.com/fonts with a proper API, ready to embed into your code. Tahoma my ass…  ::) >:(

    P.S. The entire table-based GUI mess needs to be flushed down the drain in the first place, along with the non-UTF8 encoding.


  • Banned

    Been saying that for a long time. Jdilliard is the webdev. for ESF so I guess he is on top of things :)


  • Netgate Administrator

    Just to clarify I'm not actually running at 640x480. Still had no problem using a, relatively, clean Xubuntu install.
    Clearly there is an issue though.

    Steve



  • I cleared the issue by doing a hard refresh of the page

    Ctrl-F5

    pfSense 2.1.5
    openSuse 13.1
    Firefox 31.0



  • I had this issue on 3 of my 7 pfsense boxes after the upgrade to 2.1.5.  Only in Safari, but on multiple computers.  It looked fine in firefox and IE. I restarted the browser and that fixed the issue on most of them.  One of the pfsense changed behavior after a reboot.  Which tells me resolution had nothing to do with it.