Pfsense (fiziksel ve sanal makine kurulum sorunu Hk.) (Çözüldü)



  • Merhabalar değerli arkadaşlar dün internette araştırırken pfsense ile karşılaştım (daha önce smoothwall kullanıyordum ancak sorunlar sebebiyle çalıştıramadım alternatif ararken buldum. smoothwall a göre tr desteği daha fazla forum baabıyla açıkçası bu durumda hoşuma gitti 11.000 in üzerinde post görmek güzel bu sebeple de buraya katkı koyanlara teşekkür ediyorum)
    arama kutusuna vmware sorunları arattım ancak pek fazla birşey bulamadım daha doğrusu sorunuma çare olacak bir durum değildi

    Sorunun tanımı için denemiş olduğum mevcut materyaller:

    işletim sistemi:pfSense-LiveCD-2.1-RELEASE-i386.iso (new york sunucusundan indirdim)


    sanal makine için denenen sistemler; (hp i7 masaüstü bilgisayar vmware 9 workstation tek fiziksel ethernet kartı)
    bu bilgisayara
    işletim sistemi other seçilip FreeBSD seçildi ilk ethernet kartı default olarak nat geliyor ikincisini ise host only olarak ekledim. ancak kurulum sırasında
    "wan ve lan seçiminin yapıldığı (em0 em1) sayfada a ya basıp otomatik olarak seçmesini istiyorum ancak bu işlemi yapmıyor önce wan ı sorduğu için em1 yazıyorum kabul ediyor ancak bu kez ise em0 yazabileceğim lan kısmı gelmeden kuruluma geçiyor bu sebeple yanlış yaptığımı düşünüyorum sonrasında kurulumu yapıyorum ancak doğal olarak lokalde ulaşamıyorum


    aynı sorunu (i5 hp ultrabook a kurduğum vmware workstation 9 da da yaşıyorum.)


    dün fiziksel olarak iki ethernet kartının kurulu olduğu 512mb ram ve p4 2.0 işlemcili makinemde de denedim ethernet kısmında aynı sorunlarla karşılaştım,

    sizlerden ricam en azından vmware a kurulumunu (vmware ayarları ile birlikte (fiziksel tek ethernet kartı olan ve iki ayrı sanal ethernet tanımlamasında ayarları nasıl yapacağımıza ve işletim sistemi olarak doğru olanın hangisi olacağı hussunda yardım edebilecek birisi varsa şimdiden teşekkür ederim iyi çalışmalar

    pfsense kurmamın sebebi 30 makine bulunan ağımda internet çıkışını kontrol etmeye ve hangi internet sitelerine en çok giriş yapıldığını tespit edip çok fazla trafik harcayan web sitelerini engellemeyi istiyorum



  • merhaba aynı adımları ben de yapıyorum (sanal ve fiziksel farklı makinalarda) ve herhangi bir sorun yaşamıyorum. kurulum çok basit aslında. enter a basma sırasında bir karışıklık var sanki

    "a" yani otomatik aktif edildiğinde portun up edilmesini (aktifleştirilmesini) bekliyor. Eğer zaten aktif ise bir anlamı yok. yeni bir şey gelmez. bu aşamada

    sanalda ilk kurulumda ethernet interfacelerini pasif yapıp bu aşamadayken aktife sırası ile çekerseniz otomatik tanıma çalışacaktır.
    fizikselde de kabloları sırası ile takmanız gerekiyor. yani WAN  da wan için kullanacağınız ethernete kabloyu takın. sonra entere bastığınızda lan ı sizden ister. a ya basın. sizden kabloyu takıp entere basmanızı ister tekrar. kabloyu takar entere basarsanız olanı kaydeder.

    ve kurulum aşamalarına devam edersiniz.
    ve bir şey daha bu ayarlar için her seferinde format atmanıza gerek yok. kurulumdan sonra 2. seçenek ile interface leri 3 ile de IPlerini ayarlayabiliyorsunuz.
    not: lütfen cevabı çok basit bulmayın aklıma gelen ilk hatayı yazdım.



  • Konuyla ilgili ben de sorun yaşamaktayım. Makinede 2 ethernet var her ikisi de Bridged. Söylediklerini uygulamaya çalıştım ama nafile.

    Kısacası şu ekran ile ilgili işlemi biraz daha geniş anlatabilirsen memnun olurum.



  • Size vlan ağları yani yerel ağlar oluşturacakmısınız diye soruyor eğer istemiyorsanız ''n'' ile geçiniz wan ve lan bacaklarını hangi ethernet kartlarını seçmenizi soracak



  • Baştaki soruyu okumadınız galiba.

    Ayrıca "Kısacası şu ekran ile ilgili işlemi biraz daha geniş anlatabilirsen memnun olurum. " sorusunu bir tuş ile açıklamak da güzel.

    Ben zaten sanal makinada iç ve dış bacaklarıma nasıl IP atayıp, ya da aldırıp erişim sağlayabilirm onu soruyorum.



  • Öncelikle esxi üzerinde makinanıza tıklayın, sonra "configuration" sekmesindeki "networking" sayfasına tıkladığınızda mevcut yapınız karşınıza gelecek. burada benim yapılandırmamı örnekleyebilirsiniz. 3 resimde detayları yer almaktadır. yine aklınıza takılan bir nokta olursa lütfen sorun. Bende log lama ile uğraşıyorum muhtemelen sabaha kadarda uğraşırım gibi geliyor

    Esxi üzerindeki yapılandırma ekranında gördüğünüz mac adresleri size kesinlik kazandıracaktır. mac adreslerine göre hangi kartın ne olduğunu bilebilirsiniz.ama sanal makinadan ilk eklenen le0 re0 vs gibi ilk gelecektir. ikinci ve üçüncüler (fizikselde de aynı) devamına numaralanacaktır.



  • @madbrave:

    Konuyla ilgili ben de sorun yaşamaktayım. Makinede 2 ethernet var her ikisi de Bridged. Söylediklerini uygulamaya çalıştım ama nafile.

    Kısacası şu ekran ile ilgili işlemi biraz daha geniş anlatabilirsen memnun olurum.

    Bu aşamada hangi kartın hangi networke baktığını öğrendiyseniz,
    1. "n" ye basarak şimdilik vlan ayarı yapmayacağnızı söylersiniz.
    2. WAN - internet çıkışı için hangi kartı kullanacağınızı seçmenizi ister, mac inden veya ilk eklenen kartı "le0 " yazarak seçebilirsiniz.
    3. LAN yani iç tarafa hangi kartı kullanacağınızı seçmenizi ister, mac inden veya ilk eklenen kartı "le1 " yazarak seçebilirsiniz.

    Bundan sonra ayarlar kaydedilsin mi y/n diye soracak y diyerek kurulumu sonlandırırsınız. ardından işlemler tamamlandığında karşınıza gelen menuden 99 u seçerek kurulumu HDD ye aktarırsınz. Bu arada sizden önce WAN sonra da lan için DHCP kullanılsın mı diye soracaktır. tavsiyem ilk aşamada y diyerek geçin. sonra pfsense arayüzüne girdiğinizde değişikliğe gidersiniz.



  • @fotocum:

    merhaba aynı adımları ben de yapıyorum (sanal ve fiziksel farklı makinalarda) ve herhangi bir sorun yaşamıyorum. kurulum çok basit aslında. enter a basma sırasında bir karışıklık var sanki

    "a" yani otomatik aktif edildiğinde portun up edilmesini (aktifleştirilmesini) bekliyor. Eğer zaten aktif ise bir anlamı yok. yeni bir şey gelmez. bu aşamada

    sanalda ilk kurulumda ethernet interfacelerini pasif yapıp bu aşamadayken aktife sırası ile çekerseniz otomatik tanıma çalışacaktır.
    fizikselde de kabloları sırası ile takmanız gerekiyor. yani WAN  da wan için kullanacağınız ethernete kabloyu takın. sonra entere bastığınızda lan ı sizden ister. a ya basın. sizden kabloyu takıp entere basmanızı ister tekrar. kabloyu takar entere basarsanız olanı kaydeder.

    ve kurulum aşamalarına devam edersiniz.
    ve bir şey daha bu ayarlar için her seferinde format atmanıza gerek yok. kurulumdan sonra 2. seçenek ile interface leri 3 ile de IPlerini ayarlayabiliyorsunuz.
    not: lütfen cevabı çok basit bulmayın aklıma gelen ilk hatayı yazdım.

    Merhabalar @fotocum öncelikle öneriniz BASİT değil aksine çokça YARDIMSEVER sorunun altına yazdığınız anlatım ise muhteşem bu husus için çok teşekkür ederim ancak ne yazık ki elimdeki makinelere esxi kurma imkanım yok pfsense yi ben workstationda deneme için kuruyorum asıl yapmak istediğim ise fizikselde p4 2.0 ghz 512 mb ram 80gb sata diskim var bu konfigürasyona kurmak ancak ne yaptıysam fiziksel de beceremediğim için bari sanal makineye kurup orada kurcalayayım ki daha sonra öğrendikçe hemen fiziksele geçip sistemi ayağa kaldırayımın derdindeyim bu sebeple workstation kurarken hangi ethernet ayarlarını girmem gerekli bunu bana bildirebilirseniz sevinirim yada workstation sizde de mevcutsa aşağıdaki gibi bir görsel anlatım yapabilirseniz arşivime eklemek istiyorum yardımlarınız için tekrar teşekkür eder iyi çalışmalar dilerim



  • eğer donanım tanımaması gibi bi sorun yok ise fiziksel makina kurulumunda yardımcı olabilirim. Sanal makina üzerinde de şu an için ağım ona müsayit değil. bir müşterim için esxi ile kurulum ve denemeler yapıyorum. ama bir aksilik olmaz ise yarına kadar router vs ile ağı hazırlar sanal üzerinden de stabil çalıştırıp siiznle paylaşırım.

    saygılar…



  • @fotocum:

    eğer donanım tanımaması gibi bi sorun yok ise fiziksel makina kurulumunda yardımcı olabilirim. Sanal makina üzerinde de şu an için ağım ona müsayit değil. bir müşterim için esxi ile kurulum ve denemeler yapıyorum. ama bir aksilik olmaz ise yarına kadar router vs ile ağı hazırlar sanal üzerinden de stabil çalıştırıp siiznle paylaşırım.

    saygılar…

    Merhabalar @fotocum donanım ile ilgili bir sorunum olduğunu düşünmüyorum yukarıda bahsetmemiş olabilirim sorun yaşayınca donanımda bir problem mi var diye smoothwall kurdum aynı konfigurasyona ve sorunsuz şekilde firewall üzerinden clientlerim internete çıktı (gerçi modem üzerinden çıkarken daha hızlı olan internet smooth üzerinden çıkarken daha yavaş şekilde çıkmıştı ancak bunun donanım ile alakası olduğunu düşünmüyorum

    Bu sebeple fiziksel kurulumda yardımınızı rica edebilirim



  • konuyu çözüldü olarak kapatırmısınız fiziksel makineye kurulumu başarıyla tamamladım sorun hakkındaki açıklamaya şu konudan ulaşabilirsiniz http://forum.pfsense.org/index.php/topic,70735.msg387042.html#msg387042


Log in to reply