Cant access web gui if wan is down or no ip assigned dhcp

  • I am running the latest build on a watchguard X-Core-E, setup works fine unless the wan interface goes down or looses the dhcp assigned ip, the wan iface is configured for pppoe and if it does down, so does the web gui.

    it otherwise works good.

    reboot does not fix

    restart of webconfigurator via ssh console does not fix it either.

    it is a nanobsd embedded setup

  • anyone?

  • LAYER 8 Global Moderator

    Did you just wait a bit?  When wan, ie dns is down then web gui can take a couple of minutes to load.  I believe this delay is related to trying to check for upgrade, etc.

    Under system, firmware updater settings try checking bot box not to udpate

    "Disable the automatic dashboard auto-update check."

  • Ordinarily I would start a new thread, but this issue posted from 2-3 years ago just showed up on my system.  Not sure if I am experiencing exactly the same issue… here is what I see:

    The WAN interface is changed (ISP modem is reset, etc).
    The Web GUI then becomes inaccessible.    This creates a problem as the pfsense system is not trying to get a new DHCP address from the ISP, and without the ability to get to the configurator, I cannot force a refresh of the wan DHCP.

    The only fix I have been able to come up with is to reboot the ISP device (cable modem) at the same time I reboot the pfsense box.    This is cumbersome as I run the pfsense box headless.  The only way I was able to understand what was going on was to add a monitor and keyboard, and then see that the box was actually booting fully with no WAN connectivity (and hence, no web GUI).

    Once rebooted with successful WAN connectivity, the web GUI worked as expected.

    Thanks for any insight that can be provided.

  • LAYER 8 Global Moderator

    "with no WAN connectivity (and hence, no web GUI)."

    Not sure where you got the idea that no wan connectivity means no gui??  Unless your trying to hit the gui via the wan IP?  Which yeah then that would clearly be the case ;)

    You really should start your own thread - whatever issue this poster had, he never came back and clearly since this thread is from 2014 it would of been with an out dated no longer supported version of pfsense.  Which I would assume your running current 2.3.2p1

Log in to reply