Repeatable Wireless Problem that Requires Reboots



  • Thank you for a great resource and this community who helps support it!  I am trying to resolve a problem with our church network. I am a pastor on staff, who has a software background, but not a network hardware/software background. I love learning but do not pretend to be an expert in this area. We have a 20K square foot warehouse that we’ve setup with a wired and wireless network using pfsense. It actually runs beautifully but I am trying to debug 1 specific problem. If you can give me some pointers to further debug, I’d appreciate it.

    Problem Summary:

    We have two wireless networks, a private (10.2.0.0) and a guest (10.255.0.0). The private never goes down. The public goes down frequently (1-2 times a week) and the only remedy is to recycle the power on everything WAN, pfsense box and switches.  I know the brute force non-sustainable method :-)

    Attempted Resolution:

    When it happens, the problem appears to present the same symptoms. It isn’t related to the # of users or traffic because it happens with little to no users around and no apparent rise in up/download traffic By going down, I mean the public network becomes non-responsive, from a wireless device perspective, it just times out trying to get on the guest network. A forget network and attempt acquire again doesn’t work. A ping, times out - pings done on the pfsense box or another device that has access to that network. When this happens, I’ve tried recycling the WAPs , WAPS and the public switch, WAPS, public switch and the pfsense box, just the WAN but none of that seems to work. I have to power down the pfsense box, switches and WAN to get it work again. Early on, I thought maybe it was a state issue so I scheduled pfsense to reboot every morning at 1:30am; this didn’t seem to stop this situation. I even swapped out the pfsense box to my backup which is configured the same way, same problem. Let me give you details on our network setup.

    Network Setup:

    WAN - ATT U-verse modem
    Enterprise Firewall/Router - pfsense 2.1 latest build on a dell box with 3 ports (WAN, and a dual ethernet card intel that has ports for private and public)
    Private switches(2) - Netgear Prosafe 24-Port Gigabit Switch
    Public (1) - Netgear GS108 switch
    WAPS(5) - public WAPs Cisco WAP300N. BTW, I did resolve an oversaturation issue as well as configured 2.4ghz channels to avoid interferance/co-channel/cross channel issues. I used InSSIDer to help get the channels (1,6,11) set accordingly.
    Captive Portal turned on for public network with no authentication just a welcome screen and a connect button.

    Thanks for getting this far in the note. Any wisdom on what I can try or look at will be real helpful.

    Rob
    rperry@lifepointechurch.org



  • Have you tried to replace the public switch with something else? Sound like it might be a ARP issue of some sort. If you have a redundant pfSense setup you might want shut down one server to see if it is part of your problem.