Unable to check for updates!



  • I installed nanobsd 2.1 in my laptop via virtualbox.

    I set my laptop broadcom wireless connection as the pfs WAN.

    I set my LAN as 192.168.56.10

    I can log-in to webGUI from the host machine as well as if I am to connect my other laptop to the hostmachine (laptop) I still can log in in the webGUI.

    My problem is it seems pfs is not connected to the internet, I get this message "Unable to check for updates." from the dashboard.

    Can anyone please point me to the right direction?

    I tried toying the LAN area. First as Host-Only adapter then as a bridge, to bridge my physical NIC (now used as a LAN) to connect another laptop.

    Any advise is much appreciated.



  • pfsense is required to be connected to the internet to check for updates, but by default pfsense WAN firewall rules will block traffic from internal IPs

    there is a checkbox for blocking private networks on the settings for your WAN interface, uncheck that box since you're using an internal IP address for your WAN

    and that should allow you to connect to the internet to check for updates



  • Thanks alot!

    Here's another problem.

    While waiting for a reply on my previous issue, I turned off my box alread. Just now, when I am abot to implement your solution, ran the vbox (as pfs nanobsd is running in vbox) and the pfs can't obtain connection from bridged WAN. I bridged it to the laptops broadcom wireless. Nevertheless, I unchecked the box, based on your solution, restarte the vbox, and the console no longer show any WAN, it just shows WAM > em0 > (blank)

    did I missed something?

    my laptop is connected via wifi.


Log in to reply