Forcing openvpn traffic thru pfsense gateway



  • I am using Openvpn with pfsense to allow users to vpn into the office network and access files/rdp/etc, which is working fine. What I would like is for all of their internet traffic to be routed thru our internet providers at the office while they are connected with Openvpn. Right now, when I check the reported IP address while connected with Openvpn, it is never reporting the office IP address. The reason for this request is because some of our customers only allow rdp access to their servers from our office public ip address.

    If anyone could point me in the right direction, it would be much appreciated.



  • On the OpenVPN Server page:
    Redirect Gateway - Force all client generated traffic through the tunnel.

    Check that box.

    And make sure you have wider rules on the OpenVPN tab to allow traffic from the clients that has destination general internet IPs.



  • Phil, thanks for your reply.

    I tried checking off that box and then I uninstalled then exported and reinstalled the Openvpn install from the gateway page. I am able to connect to the vpn but now I cannot ping or access anything on the office network and cannot access the internet.

    It looks like a rule was added for openvpn when I enabled it that says to pass traffic from openvpn with any protocol, any source, and any destination. I am assuming that is what you meant when you said "make sure you have wider rules on the OpenVPN tab to allow traffic from the clients that has destination general internet IPs."

    update*** I tried again and was able to ping the pfsense gateway and some pc's in the network but still cant get out to the internet.


Log in to reply