3g dongle crash the box on reboot when in modem mode



  • it seems this bug still exists, i have tried multiple dongles from nokia, dlink to huwaei, even some of the ones listed in the known working dongle list but when i have a dongle active and working and if the box was rebooted, the system would simply hang on the part where it says USB disconnecting and the only way past it is to unplug and reset and replug while rebooting and this isnt easily possible when remotely managing other boxes.

    Same machine running windows and same dongle under it reboots just fine so it cant be that the hardware is faulty or the bios having issues. I tried this on 3 separate boxes and its the same. Some dongles need that modeswitch program to switch them to modem mode from the default storage mode and the modes switch also fine but when in modem mode reboot hangs but when in storage mode it reboots fine


  • Rebel Alliance Developer Netgate

    That's not likely to see attention for 2.1.1. It's not a regression and there isn't much we can do. Once we get 2.2 snapshots going, try it there and see.


Log in to reply