Pfsense + squid + p2p + battle.net



  • Здравствуйте. Имеется шлюз pfsense + squid. Squid настроен как прозрачный. Проблема в том что есть программа battle net agent которая обновляется и качает игры blizzard через p2p сеть и получает seed с хостов на 80 порту. Так вот squid не пускает эту программу. Пробовал открывать все порты и разрешал метод connect - не помогает. Пробовал добавить один хост в Bypass proxy for these destination IPs. через этот хост пошла загрузка но на остальных застопорилась. Хостов тьма так что все их отследить и вписать не получится. Подключался к другому шлюзу с kerio и его прозрачным прокси - все работало. Помогите советом.



  • На скольких локальных хостах работает battle net agent?



  • на одном моем компе)



  • @6en9er:

    на одном моем компе)

    Ну дак добавить его в Bypass proxy for these sources IPs.



  • я пробовал добавить, но отвалилось все связанное с 80 портом( порт открывал 80), а потом надо чтоб мой хост тоже ходил через проксю



  • Смените порт в battle.net на 8080 и правилами НАТ файрвола поправьте исходящий трафик со своего IP 8080 > 80

    я пробовал добавить, но отвалилось все связанное с 80 портом( порт открывал 80), а потом надо чтоб мой хост тоже ходил через проксю

    Ну есс-но, если нет соответствующих разрешающих правил в файрволе. Все исключения из сквида попадают в обработку на файрвол.



  • Я бы с радостью но в программе нет возможности менять что либо.



  • По поводу правил firewall я ж написал что открыл 80 порт себе.



  • @6en9er:

    По поводу правил firewall я ж написал что открыл 80 порт себе.

    Увидел, но значит что-то не докрутили (dns к примеру). Без вида правил ничего не скажу

    @6en9er:

    Я бы с радостью но в программе нет возможности менять что либо.

    Других решений, к сожалению, не вижу.

    Попробуйте в custom options поиграться с connect, но это такая-же дырка, что и bypass proxy. Исходные данные в виде виде destination не определены, не-HTTP протокол squid анализировать не умеет.



  • Была такая же фигня. Просто включил Services: UPnP & NAT-PMP и все заработало.



  • @Dave77:

    Была такая же фигня. Просто включил Services: UPnP & NAT-PMP и все заработало.

    Я этими сервисами не пользовался. Опишите пожалуйста проблему и решение в FAQ.



  • напрямую удалось подключиться, в правилах firewall нашел ошибку). Но хотелось бы именно оставить прокси. По поводу UPNP, не могу включить этот сервис ибо сеть корпоративная( и нельзя такие дыры оставлять пользователям.
    На другом шлюзе как то же работает под прозрачным прокси! я думаю и на pfsense можно как то сделать!



  • @6en9er:

    напрямую удалось подключиться, в правилах firewall нашел ошибку). Но хотелось бы именно оставить прокси. По поводу UPNP, не могу включить этот сервис ибо сеть корпоративная( и нельзя такие дыры оставлять пользователям.
    На другом шлюзе как то же работает под прозрачным прокси! я думаю и на pfsense можно как то сделать!

    На другом шлюзе, я думаю, используется функция анализа трафика. В Керио она встроена с самого его начала.
    В организации прозрачного прокси там скорее всего заворачивается весь HTTP(s) трафик.
    В pfSense заворачивается весь трафик по 80 порту.

    Что можно сделать.
    Настроить контейнер Layer2 для HTTP(s). Отключить прозрачный режим в Squid. Создать ручное правило прозрачного перенаправления с подключенныи Layer2 HTTP(s).



  • @6en9er:

    напрямую удалось подключиться, в правилах firewall нашел ошибку). Но хотелось бы именно оставить прокси. По поводу UPNP, не могу включить этот сервис ибо сеть корпоративная( и нельзя такие дыры оставлять пользователям.
    На другом шлюзе как то же работает под прозрачным прокси! я думаю и на pfsense можно как то сделать!

    Странно, сеть корпоративная, а у Вас игрушки не работают. :)
    Просто включите (укажите какие интерфейсы куда смотрят и галку на Enable) и посмотрите, что будет.



  • скажите если в фаерволе открыт порт 80 то трафик идет мимо прозрачного прокси или обязательно надо прописывать Bypass proxy for these source IPs?



  • @Dave77:

    @6en9er:

    напрямую удалось подключиться, в правилах firewall нашел ошибку). Но хотелось бы именно оставить прокси. По поводу UPNP, не могу включить этот сервис ибо сеть корпоративная( и нельзя такие дыры оставлять пользователям.
    На другом шлюзе как то же работает под прозрачным прокси! я думаю и на pfsense можно как то сделать!

    Странно, сеть корпоративная, а у Вас игрушки не работают. :)
    Просто включите (укажите какие интерфейсы куда смотрят и галку на Enable) и посмотрите, что будет.

    Захотелось в hearthstone поиграть в обед а тут облом. UPNP я знаю как включать просто не должен грубо говоря)



  • вобщем все проблемы решились зачисткой папки temp в папке пользователя. Все работает без проблем через проксю. Тему можно закрыть