Problemas servicio captive portal!



  • Hola a Todos instale mi Servidor Pfsense en una maquina virtual y todo va de mil maravillas, hasta que ayer note que el servicio de captive portal estaba parandose solo no se porque ya lleva un mes que estaba todo perfecto.

    que sera que esta aconteciendo?

    mi red wifi es de acceso masivo llega hasta 3000 usuarios por dia me ayuden con algo.




  • Saludos!! Creo que lo primero que deberias hacer es chequear lo logs de pfsense para descartar el problema sea pfsense o determinar la causa efectiva de la parada de Captive Portal. Ahora bien tambien vendria bien saber si primeramente esos 3000 Usuarios que nombras son tus clientes? y o el uso del Captive Portal actualmente en tu red de servicios…



  • entonces uso un radius server 2012 r2 para autenticar con el AD, verifique los logs y aparece esto

    
    Feb 10 21:15:10 	php: /index.php: Successful login for user 'admin' from: 172.16.142.8
    Feb 10 21:15:10 	php: /index.php: Successful login for user 'admin' from: 172.16.142.8
    Feb 10 21:15:18 	lighttpd[47938]: (request.c.1145) POST-request, but content-length missing -> 411
    Feb 10 21:15:22 	php[20376]: /index.php: Submission to captiveportal with unkown parameter zone: home
    Feb 10 21:15:34 	kernel: arp: 172.16.24.68 moved from f8:d0:bd:62:04:21 to 94:51:03:df:bf:6f on em0
    Feb 10 21:16:03 	lighttpd[47938]: (mod_evasive.c.183) 172.16.158.46 turned away. Too many connections.
    Feb 10 21:16:03 	lighttpd[47938]: (mod_evasive.c.183) 172.16.158.46 turned away. Too many connections.
    Feb 10 21:16:10 	lighttpd[47938]: (request.c.1133) GET/HEAD with content-length -> 400
    Feb 10 21:16:13 	lighttpd[47938]: (request.c.1133) GET/HEAD with content-length -> 400
    Feb 10 21:16:16 	lighttpd[47938]: (request.c.1133) GET/HEAD with content-length -> 400
    
    Feb 10 21:24:34 	lighttpd[47938]: (connections.c.137) (warning) close: 58 Connection reset by peer
    Feb 10 21:24:57 	lighttpd[47938]: (request.c.1133) GET/HEAD with content-length -> 400
    Feb 10 21:25:10 	lighttpd[47938]: (request.c.1145) POST-request, but content-length missing -> 411
    Feb 10 21:25:45 	lighttpd[47938]: (request.c.1133) GET/HEAD with content-length -> 400
    Feb 10 21:26:13 	lighttpd[47938]: (mod_evasive.c.183) 172.16.99.5 turned away. Too many connections.
    
    Feb 7 07:20:06 	php: rc.prunecaptiveportal: Skipping CP prunning process because previous/another instance is already running
    Feb 7 07:22:47 	php: rc.prunecaptiveportal: Skipping CP prunning process because previous/another instance is already running
    Feb 7 07:25:27 	php: rc.prunecaptiveportal: Skipping CP prunning process because previous/another instance is already running
    Feb 7 07:28:08 	php: rc.prunecaptiveportal: Skipping CP prunning process because previous/another instance is already running
    
    Feb 8 10:58:25 	php[68065]: /index.php: Submission to captiveportal with unkown parameter zone: sdnews1
    Feb 8 10:58:55 	php[68065]: /index.php: Submission to captiveportal with unkown parameter zone: searchdesk_01
    Feb 10 17:57:12 	minicron: (/etc/rc.prunecaptiveportal) terminated by signal 15 (Terminated: 15)
    Feb 10 21:15:22 	php[20376]: /index.php: Submission to captiveportal with unkown parameter zone: home
    
    

    yo no se pero creo que el lighttpd se esta cayendo o que opinan ustedes



  • Google lighttpd mod_evasive turned away Too many connections site:forum.pfsense.org

    ¿Hiciste algún upgrade recientemente?

    En uno de los posts dicen haber hecho un upgrade y terminar por hacer una instalación nueva para solucionar el problema.

    En otro dicen que es un exceso de conexiones simultáneas a la web del portal. Igual tienes a alguien intentando hacerlo caer.

    Google lighttpd mod_evasive turned away Too many connections –-> si quieres ver no restringido al fórum.



  • Saludos mi estimado, como indica el maestro bellera a mi me parece que existe algún usuario conectado al portal intentando hacer bucles estilo ataques evil twin para  hacerlo caer. Usando aplicaciones de scanner podrías ver si esto esta pasando en tu red de servicios. Estamos a la orden


Log in to reply