Can't connect PPP



  • Hi

    can't use my huawei e392-u12

    Feb 8 19:57:49 ppp: [opt1_link0] Link: reconnection attempt 122
    Feb 8 19:57:47 ppp: [opt1_link0] Link: reconnection attempt 122 in 2 seconds
    Feb 8 19:57:47 ppp: [opt1_link0] LCP: Down event
    Feb 8 19:57:47 ppp: [opt1_link0] Link: DOWN event
    Feb 8 19:57:47 ppp: [opt1_link0] MODEM: can't open chat script file
    Feb 8 19:57:47 ppp: OpenConfFile: Can't open file '/var/etc/mpd.script': No such file or directory

    Version
    2.1.1-PRERELEASE (amd64)
    built on Fri Feb 7 09:57:48 EST 2014
    FreeBSD 8.3-RELEASE-p14

    You are on the latest version.

    [2.1.1-PRERELEASE][admin@pfsense.*****.local]/var/etc(17): vi mpd_opt1.conf
    startup:
            # configure the console
            set console close
            # configure the web server
            set web close

    default:
    pppclient:
            create bundle static opt1
            set bundle enable ipv6cp
            set iface name ppp1
            set iface disable on-demand
            set iface idle 0
            set iface enable tcpmssfix
            set iface up-script /usr/local/sbin/ppp-linkup
            set iface down-script /usr/local/sbin/ppp-linkdown
            set ipcp ranges 0.0.0.0/0 10.64.64.1/0
            set ipcp enable req-pri-dns
            set ipcp enable req-sec-dns
            #log -bund -ccp -chat -iface -ipcp -lcp -link

    create link static opt1_link0 modem
            set link action bundle opt1
    mpd_opt1.conf: unmodified: line 1


  • Rebel Alliance Developer Netgate

    Was this working before on 2.1.1 and broke with that snapshot? Or has it never worked for you on 2.1.1?



  • Hi Jimp

    Seeing the RRD Graphs, i lost ppp Thursday night (snapshot  6 February). I remember using 31 Jan, 4 Feb, 6 Feb and 7 Feb snaps. Now i have the stable 2.1

    My Setup:

    • MB: Asrock wolfdale1333-d667 http://www.asrock.com/mb/intel/wolfdale1333-d667/
    • Cpu: Celeron(R) CPU E1200
    • DDR2 2GB dual channel team elite.
    • Sata to CF adapter (Marvel chipset )
    • Networks -  intel dual GB 1000 Pt and huawei e392-u12 (locked to  LTE)

    Edit:

    • pfSense-2.1.1-PRERELEASE-4g-amd64-nanobsd_vga-upgrade-20140205-1409.img.gz (edit 2: ppp doesn't work i have to do a ln -s /usr/local/sbin/mpd.script /var/etc/mpd.script to solve the problem ).
    • pfSense-2.1.1-PRERELEASE-4g-amd64-nanobsd_vga-upgrade-20140204-2041.img.gz (need patch)
    • pfSense-2.1.1-PRERELEASE-1g-amd64-nanobsd_vga-upgrade-20140204-0232.img.gz (edit 3: Works fine without patch)
      Aside note, probably not related, i have to  Restart webConfigurator to change settings maybe a day or less before i do another Restart webConfigurator or reboot. Some time i have to do a hard reboot to boot (to refresh my huawei e392-u12, after unplug usb i have to reboot pfSense, otherwise i can't connect - stable 2.1 and i think 2.01 and 2.02). But this is for another topic.

  • Rebel Alliance Developer Netgate

    Renato spotted an issue with the mpd script and put in a fix, snapshots dated after this post should be OK



  • Thanks

    I see the fix,  should be OK buy i will test and give feedback.

    https://redmine.pfsense.org/projects/pfsense/repository/revisions/5833def1a5ccd4b625ff07349c4060a33772d897.

    Can i change the 3G icon for the LTE or 4G? Its´s a cosmetic thing but… .Cell Mode is reporting wrong information, currently i have "None, No Service Mode" sometime i have a 3G mode in locked LTE Mode USB.



  • Problem solved  :). Thanks

    2.1.1-PRERELEASE (amd64)
    built on Tue Feb 11 22:10:33 EST 2014
    FreeBSD 8.3-RELEASE-p14