MTU errors



  • Hello all,

    I am using a pfSense box with a VPN service. I am contemplating using different ones.  I am using VPN Express and on certain servers the config works and I get no errors in the OpenVPN logs. But I switched to another one of their servers and I got the following errors:

    Feb 10 00:05:58 openvpn[24030]: WARNING: 'link-mtu' is used inconsistently, local='link-mtu 1542', remote='link-mtu 1546'

    Feb 10 00:05:58 openvpn[24030]: WARNING: 'mtu-dynamic' is present in remote config but missing in local config, remote='mtu-dynamic'

    Again, on another one of their servers I get no errors.  How do I fix this particular error?

    Thanks



  • I changed the local config file so that the mtu value matches the warning but that then generates a similar tun-mtu error.

    I got a different error below when I changed the mtu to 1500

    Feb 10 00:32:37 openvpn[87806]: WARNING: 'link-mtu' is used inconsistently, local='link-mtu 1500', remote='link-mtu 1546'
    Feb 10 00:32:37 openvpn[87806]: WARNING: 'tun-mtu' is used inconsistently, local='tun-mtu 1458', remote='tun-mtu 1500'
    Feb 10 00:32:37 openvpn[87806]: WARNING: 'mtu-dynamic' is present in remote config but missing in local config, remote='mtu-dynamic'

    Here is the local config? I can't see the server side since its on VPN Express.

    dev tun
    fast-io
    persist-key
    persist-tun
    replay-persist cur-replay-protection.cache
    nobind
    remote x.x.x.x
    remote-random
    pull
    comp-lzo
    tls-client
    tls-remote server
    ns-cert-type server
    verb 3
    key-direction 1
    route-method exe
    route-delay 2
    tun-mtu 1500
    fragment 1300
    mssfix 1450



  • I am experiencing the same problem.

    I have my pfSense box connected to StrongVPN and I see this in the logs:

    WARNING: 'link-mtu' is used inconsistently, local='link-mtu 1558', remote='link-mtu 1562'
    WARNING: 'mtu-dynamic' is present in remote config but missing in local config, remote='mtu-dynamic'

    When I put tun-mtu 1500 in the Custom Options, like you the warning changes.