Searching for IP6 gateway even if I disabled it



  • pfSense keeps on searching for an IP6 gateway, even if I disabled it on the interface:

    The log keeps telling me:

    php: rc.filter_configure_sync: Could not find IPv6 gateway for interface(opt1).
    
    Feb 10 12:46:24 	php: rc.start_packages: Restarting/Starting all packages.
    Feb 10 12:46:22 	php: rc.filter_configure_sync: Could not find IPv6 gateway for interface(opt1).
    Feb 10 12:46:22 	php: rc.filter_configure_sync: Could not find IPv6 gateway for interface(wan).
    Feb 10 12:46:22 	check_reload_status: Starting packages
    Feb 10 12:46:22 	php: rc.newwanip: pfSense package system has detected an ip change -> 192.168.8.1 ... Restarting packages.
    Feb 10 12:46:22 	php: rc.newwanip: rc.newwanip: on (IP address: 192.168.8.1) (interface: ) (real interface: ovpns1).
    Feb 10 12:46:22 	php: rc.newwanip: rc.newwanip: Informational is starting ovpns1.
    Feb 10 12:46:19 	check_reload_status: rc.newwanip starting ovpns1
    Feb 10 12:46:19 	php: rc.filter_configure_sync: Could not find IPv6 gateway for interface(opt1).
    Feb 10 12:46:19 	kernel: ovpns1: link state changed to UP
    Feb 10 12:46:19 	php: rc.filter_configure_sync: Could not find IPv6 gateway for interface(wan).
    Feb 10 12:46:19 	check_reload_status: Reloading filter
    Feb 10 12:46:19 	kernel: ovpns1: link state changed to DOWN
    Feb 10 12:46:19 	php: rc.openvpn: OpenVPN: Resync server1 OpenVPN WAN
    Feb 10 12:46:19 	php: rc.openvpn: OpenVPN: One or more OpenVPN tunnel endpoints may have changed its IP. Reloading endpoints that may use GW_WAN.
    Feb 10 12:46:16 	check_reload_status: Reloading filter
    Feb 10 12:46:16 	check_reload_status: Restarting OpenVPN tunnels/interfaces
    Feb 10 12:46:16 	check_reload_status: Restarting ipsec tunnels
    Feb 10 12:46:16 	check_reload_status: updating dyndns GW_WAN
    Feb 10 12:45:02 	php: rc.filter_configure_sync: Could not find IPv6 gateway for interface(opt1).
    Feb 10 12:45:01 	php: rc.filter_configure_sync: Could not find IPv6 gateway for interface(wan).
    Feb 10 12:30:39 	php: rc.update_urltables: /etc/rc.update_urltables: pfBlockerBadIPList does not need updated.
    Feb 10 12:30:39 	php: rc.update_urltables: /etc/rc.update_urltables: Starting URL table alias updates
    Feb 10 12:30:02 	php: rc.filter_configure_sync: Could not find IPv6 gateway for interface(opt1).
    Feb 10 12:30:01 	php: rc.filter_configure_sync: Could not find IPv6 gateway for interface(wan).
    Feb 10 12:30:01 	php: rc.update_urltables: /etc/rc.update_urltables: Sleeping for 37 seconds.
    Feb 10 12:30:01 	php: rc.update_urltables: /etc/rc.update_urltables: Starting up.
    




  • Is IPv6 enable on LAN? Along with Automatic Outbound NAT, the system would automatically generate some NAT rules on WAN… and maybe cause this when it looks for a way out for IPv6.
    Or do you still have any rules that specify IPv6 protocol?



  • Yes, on the LAN interface there is IP6 as static interface. I will disable that and look if the messages are still there.



  • @phil.davis:

    Is IPv6 enable on LAN? Along with Automatic Outbound NAT, the system would automatically generate some NAT rules on WAN… and maybe cause this when it looks for a way out for IPv6.
    Or do you still have any rules that specify IPv6 protocol?

    Ok I did what you told me to do, removed IP6 static ip from LAN, removed all IP6 rules and disabled IP6 in System->Advanced->Networking.
    Even changed the "DOWN" monitoring of the gateway back from 60sec to de default 10sec.

    Now ALL the messages are gone, even the OpenVPN messages and gateway timeouts are gone as well!

    Maybe the other post (https://forum.pfsense.org/index.php/topic,72289.0.html)  is having the same issues due to IP6?


  • Banned

    @digdug3:

    Maybe the other post (https://forum.pfsense.org/index.php/topic,72289.0.html)  is having the same issues due to IP6?

    There is no such relation unless you assign the OpenVPN interface (which you should NOT do in 99% of cases.)