Voucher Sync not working properly



  • Hello,

    i have the latest snapshot installed, then i need the voucher sync function. Because the settings on the 2.1 version will not be saved. This has been fixed with the 2.1.1.

    Snapshot:
    2.1.1-PRERELEASE (amd64)
    built on Mon Feb 10 07:10:21 EST 2014

    Maybe but I have found an bug in 2.1.1.

    I have two pfsense, one master one slave.

    On the master i have a voucher roll for one day.

    When i test a voucher on the master at Status –> Captive Portal --> Test Voucher

    It says:

    z8cpHbRrRDm (1/36) good for 1440 Minutes
    Access granted for 1440 Minutes in total.

    on the second pfsense its the same. All good so far.

    Now when i use the expire function on the master (Status –-> Captive Portal ---> Expire Vouchers) and test the voucher on the master it says:

    z8cpHbRrRDm (1/36) already used and expired
    Access denied!

    But on the second pfsense is the voucher still valid and can be used.

    Edit:
    And for the voucher Sync function, it would be helpful to know that the "Zonename" must be identical on both sides. A hint or a better error message. ;)

    Best regards


  • Rebel Alliance Developer Netgate

    How exactly do you have the voucher sync settings configured?



  • Only on the second pfsense under    Captive Portal –-> "My Captive Portal" ---> Vouchers
    See the attached screenshot.

    10.0.10.254 is the IP of the master pfsense.




  • The problem is still on built on Sun Feb 16.

    I can also use one voucher of a client that connect to the master pfSense and the same voucher i can use on a client at the second or third pfSense.

    Master pfSense:

    Secend pfSense:


  • Banned

    +1, expired vouchers just do not sync.

    Also, I'd like to set up a dedicated user for the sync purpose (not admin) however all my attempts failed miserably due to nonexistent documentation on required privs.



  • I pushed some fixes which should help with this.

    Can you try latest code from github or next snapshot?


  • Banned

    Thanks, will test the next snapshot, the boxes are one week behind latest anyway. :-)



  • I have tested the build  Sun Feb 23.

    On the master pfsense i created new voucher rolls but the comment don't show:

    After I put a voucher has expired on the master pfsense, they are still valid on the second pfsense



  • Can you try once more with tomorrows snapshots.



  • Test: 2.1.1-PRERELEASE (amd64) built on Tue Feb 25 08:50:01 EST 2014

    I use a new voucher. On both pfsense is the voucher valid. (Status –-> Captive Portal --> Test Voucher)

    But when I try to login on the captive portal page at the second pfsense the voucher is immediately invalid.

    On the master pfsense is still valid.


  • Banned

    @Schwabe:

    But when I try to login on the captive portal page at the second pfsense the voucher is immediately invalid.
    On the master pfsense is still valid.

    Hmmm, yeah, this is actually a whole lot worse than before, perhaps just revert it. :)



  • Did you try with new snapshots or not?



  • Yes
    Snapshot: pfSense-Full-Update-2.1.1-PRERELEASE-amd64-20140225-0849.tgz


  • Banned

    Yeah, I tried with the Feb 25 snapshot. This actually is getting worse instead of better, claiming valid vouchers to be invalid is just completely wrong.



  • @ermal, can you look again? :)



  • Should be fixed for good.

    At least now it works on my test environment.

    Please test latest snapshots.



  • Thanks ermal, now it works fine!

    But one bug left. :)
    The comment field still empty.


  • Banned

    No problem with comment field. (Has also nothing to do with the original problem here which indeed has been fixed. Thanks.)


Log in to reply