Problema con X-Forwarder-For



  • tengo un problema, adjunto explicación:

    El problema reside en que se valida el rango de IPs de redSara correctamente (10.0.0.1-10.255.255.254), pero se utiliza el identificador X-Forwarded-For de la cabecera de la request para obtener la IP origen y validarla. Al utilizar IPs públicas en vuestros puestos de trabajo la iP que se obtiene  es la de origen, por lo que la conexión se trata como si fuera de internet.
    La  solución más sencilla podría ser modificar esta cabecera en proxy  forzándola a que sea la del proxy corporativo.

    como se hace?? nivel usuario novato, o menos :)





  • uf entiendo que debe ser sencillo, pero mi nivel de conocimiento raya el analfabetismo, eso se hace directamente en la maquina donde está instalado, no? en la interface web, no se puede hacer, tengo heredada la version:

    Current version: 1.2.3-RELEASE

    y me da yuyu actualizar, por desconocimiento a la  2.1-RELEASE



  • Usa Custom Options en la WebGui de pfSense para squid.



  • añadido el paquete Squid proxy y deshabilitado el X-forwaded, gracias