OpenVPN failure after upgrade from 2.0.3 to 2.1 Release



  • Hi,

    I tried to upgrade the pfSense firewall of a network  I remotely look after.
    I have OpenVPN running on pfSense and use it to access and administer the site.
    The upgrade from 2.03 to 2.1 completed successfully but OpenVPN did not function.
    The dashboard widget reported that it could not connect to the service, incoming client connections failed.
    I found a number of articles via Google, but was unable find a solution.
    Finally I had to wind the installation back to 2.0.3 as I ran out of time.
    I would like to move the site to the 2.1 release, so does anyone know what has to be done after the upgrade to allow OpenVPN to work?

    Thanks in advance for you assistance.



  • i've updated numerous sites from 2.0.3 to 2.1 without openvpn issues.
    what do/did the openvpn logs say ? anything usefull ?



  • Hi

    The logs did not give anything useful that I could see.
    The dashboard also reported an error connecting to the daemon.
    Trying to connect with a remote client did not put anything into the logs.

    Unfortunately I had to roll the machine back by reinstalling 2.0.3 and reapplying the old config so the logs were lost at that point.
    We do not have the hardware to build a test machine for changeover, so this was a production box upgrade.

    I am trying to simulate the environment by building a 2.0.3 version on a virtual machine and then doing an upgrade, but this makes it much harder to set up an OpenVPN link.

    Thanks for your assistance



  • I built a test firewall machine and network as a virtual machine. Installed and configured 2.0.3 with OpenVPN working.

    When I upgraded the test system (using System / Firmware / Upgrade) to 2.1 to try and reproduce the issue, the upgrade to 2.1 went well just as it did previously, and and the test system OpenVPN worked directly with no configuration changes required.

    I am not sure what might have caused a difference, but next step to retry update of production firewall again. I will post progress…



  • Upgraded successfully to latest rev. OpenVPN worked correctly this time. Not able to determine cause of previous failure.

    Thanks to the team.



  • i am with the similar problem, after upgrade to 2.1.3 it is not installing the OpenVPN package, please anyone help….. :'(



  • Hi all,

    Same problem here after upgrade, sort of….
    I had the openvpn service not running so I created another openvpn and that was running, I've disabled the old one and all was fine until this morning when the service went down and will not start again.
    This is what the log says:

    May 7 08:55:52 openvpn[51880]: Exiting due to fatal error
    May 7 08:55:52 openvpn[51880]: Cannot open TUN/TAP dev /dev/tun3: Device busy (errno=16)
    May 7 08:55:52 openvpn[51880]: TUN/TAP device ovpns3 exists previously, keep at program end
    May 7 08:55:52 openvpn[51880]: Control Channel Authentication: using '/var/etc/openvpn/server3.tls-auth' as a OpenVPN static key file
    May 7 08:55:51 openvpn[51880]: NOTE: the current –script-security setting may allow this configuration to call user-defined scripts
    May 7 08:55:51 openvpn[51880]: OpenVPN 2.3.2 i386-portbld-freebsd8.3 [SSL (OpenSSL)] [LZO] [eurephia] [MH] [IPv6] built on Mar 27 2014

    Any ideas?



  • Exactly the same errors with eyeballpaul after my upgrade to 2.1.3… :o



  • Just upgraded to 2.1.3 and it fixed the problem….

    /CS I suggest you revert back to previous version and install a new one again...see what happens



  • I downgraded to 2.1.2 (backup restore) but the OpenVPN service does not start because of the same error. I upgraded again to 2.1.3 and the problem has now been solved.


Log in to reply