[Résolu] chipset Atheros WIFI et SMP



  • Bonjour,
    je viens de me monter une machine (celeron dernière génération (dual core) et une image embedded sur compactflash) pour pfsense avec une carte Wifi TP-LINK TL-WN951N.
    La carte wifi est bien reconnue, tout se passe bien jusqu'au moment où un client se connecte au point d'accès (carte OPT dans pfsense).
    Au bout d'une minute, le système freeze pour de bon.
    J'ai vu ce sujet https://forum.pfsense.org/index.php/topic,42385.msg218835.html#msg218835 sur le forum, mais il est assez vieux, et un autre sujet ailleurs qui dit que ce problème vient du fait que le pilote atheros n'aime pas les kernel SMP (ici : https://forums.freebsd.org/viewtopic.php?&t=22359 pour les curieux).
    D'où ma question : comment faire pour booter sans SMP ?
    Merci d'avance !
    JFG



  • Bonsoir,

    Ca ne répondra pas directement à la question mais perso tant qu'a monter une machine spécifique j'aurrai choisit la carte avec prudence et aurrai consulter : http://www.freebsd.org/releases/8.3R/hardware.html#WLAN

    Surtoût si celle-ci doit servir de pint d'accè :) ^^

    cordialement



  • Peut etre en modifiant les parametres dans /boot/loader.conf ?
    Une piste peut etre, sans certitude aucune : http://unix.derkeiler.com/Mailing-Lists/FreeBSD/hackers/2012-04/msg00147.html
    Mais c'est freebsd 9 …



  • @baalserv:

    Ca ne répondra pas directement à la question mais perso tant qu'a monter une machine spécifique j'aurrai choisit la carte avec prudence et aurrai consulter : http://www.freebsd.org/releases/8.3R/hardware.html#WLAN

    Salut,
    merci pour la réponse. J'ai jeté un oeil à la HCL, et ai vu que tout ce qui était atheros était pris en compte. C'est vrai que je ne me suis pas posé plus de questions….. Si ça ne veut pas, je la garderai pour plus tard et la changerai dans l'immédiat par une carte 10/100 et un point d'accès séparé.
    Merci ccnet, je jette un oeil et vous dis.
    Bon dimanche !



  • Merci ccnet !
    J'ai donc jeté un oeil au dmesg pour noter le numéro du core (2) que je souhaitais invalider.
    Ensuite, j'ai modifié le /boot/loader.conf en rajoutant la ligne suivante :

    hint.lapic.2.disabled=1
    

    Après le reboot, le dmesg m'affiche ça

    
    FreeBSD/SMP: Multiprocessor System Detected: 1 CPUs
    FreeBSD/SMP: 0 package(s) x 2 core(s)
     cpu0 (BSP): APIC ID:  0
      cpu (AP): APIC ID:  2 (disabled)
    
    

    Et après avoir configuré le mode AP sur l'OPT1, tout baigne.
    Mon client se connecte bien et télécharge bien de gros fichiers sans que pfsense ne sourcille !
    Merci encore, et bon dimanche !
    JFG