Forzar navegacion



  • Buenas tardes, tenemos varias interfaces configuradas, entre ellas dos ADLS (1 WAN, 1 OPT1) y 1 LAN con un proxy transparente (Squid+Squid Guard) sobre la LAN.  LLevamos varios días buscando información de cómo hacer para forzar que la navegación HTTP de uno de los equipos conectados a la LAN salga por la OPT1.

    Dicha configuración creo recordar que se hacía configurando una regla en el Firewall indicándole los parámetros y la gateway que queremos usar, pero con el proxy transparente no se si nos funcionará. Hemos probado a crear dicha regla en cada una de las interfaces y nada el equipo sigue navegando por la WAN.

    ¿Alguien sabría indicarnos cómo hacerlo?

    Gracias.



  • ¿Habeis intentado sortear el proxy con una Floating Rule para ese equipo?



  • Mira  a ver si te sirve.

    Squid esta dificil que pueda usar mas de 1 provedor, lo han hecho pero es algo complicado si mal no recuerdo.

    Bien, por defaul pfsense solo puede tener 1 solo gw por default, entonces todo el trafico los servicios haran uso del gw default.

    Ejemplo: Telmex y cablemas.

    Default: telmex.
      securdario: cablemas.

    Ahora, squid todo su trafico lo enrutara por el default, pero yo hice lo siguiente:

    1; Default gw: Telmex, 2do cablemas
    2; Cree un alias con las personas que no necesitan el proxy ellos usaran el gw cablemas(secundario).
    3; El resto lo force a usar el proxy.
    4; En las reglas del firewall a mi alias en la parte avanzada(advanced) le djie que esos IP tienen que usar el gw cablemas.

    Con esto, squid usa telmex y los que yo quiero usan cablemas.

    No fue tan complicado al final, espero te sirva, saludos.



  • periko, estás en lo cierto si no usan transparente… pero como dijeron que lo tenían en modo transparente... de ahí el problema, pienso.



  • Eso si, cambiarlo de modo no es tanto rollo, a ver que dice..

    Saludos profe.



  • Buenas, no se por ahora si lo que estoy aplicando será correcto o no, pero por las primeras pruebas parece que todo esta correcto. Lo que hemos hecho es a añadir en Service - Proxy Server - Cumston options la línea tcp_outgoing_address 127.0.0.1; y hemos creado una regla en Firewall - Rules - Floating en el que redirigimos el trafico HTTP por la segunda ADSL.

    Por ahora las pruebas que hemos realizado son correctas.

    Gracias.


Log in to reply