Problem with Vista (Again)



  • I am having terrible problems with Vista and using Wireless with Pfsense 1.2RC3  Vista works fine with an old WRT54G WAP, no problems.  Same machine, booted with Ubuntu works fine as well connecting to the Pfsense box via wireless.

    I have found that running vista and associated with the PfSense wireless, that I can get an IP address.  I can also ping the interface of the Pfsense wireless card, as well as the LAN interface.  When I try to ping through the Pfsense box to the internet, I get about 75% packet loss.  Immeadiately boot Unbuntu on the same hardware/setup and thing are fine.

    This has been going on for about two weeks, and had me frustrated, until I found:

    http://forum.pfsense.org/index.php/topic,2098.0.html

    I know it's a locked topic on the forum, but as soon as I ran the command "netsh interface tcp show global" as administrator everything works fine?



  • Yeah I can believe it. Thats for the info. I'm not impressed with Vista. I had issues where I couldn't browse any Windows 2003 Server shares. Ran two netsh commands and it works fine. Why it couldn't come set like that out of the box is beyond me.



  • Well,  I need to eat what I posted earlier.  I ran fine the entire day yesterday across multiple reboots in Vista.  Today I booted in the AM and the same problem rears its ugly head again.  I can ping the Pfsense box, but I cannot get through the Pfsense box to the internet?

    Anyone have any ideas?



  • Try running these two commands. They did the trick to get Vista talking to Windows 2003 server. Might work for pfSense.

    
    netsh int tcp set global autotuninglevel=disabled
    netsh int tcp set global rss=disabled
    
    

Log in to reply