OpenVPN site-to-site after upgrade cannot bind to WAN, bug or not?

  • Hello,

    Few days ago I've upgraded my pfSense from 2.0.1 to 2.1 versions. After upgrade my OpenVPN site-to-site PSK configuration stopped working. I've tried many ways to diagnose the problem and have read many forum topics before I've noticed in "Diagnostic -> Sockets" that my OpenVPN server is now listening for 1194 port on LAN interface instead of WAN! I've immediately looked in server configuration, but there was WAN selected in "Interface" option.

    It's interesting that my second OpenVPN server instance configured for Roadwarrior access was working good after upgrade and it was still listening on 1194 port at WAN address as it was before upgrade.

    I've tried to change "Interface" option to "Any", then to "LAN", then to "WAN" againg, but even after restarting of OpenVPN service and atfer reboot that server instance still was listening only on LAN address. So now as a work-around I've created port-forwarding rule like "WAN Adress:1194 -> Lan adress:1194" and now VPN working fine. But I still cannot realise is it a bug or what?

Log in to reply