Problemas Portal Cautivo



  • Hola os expongo mi problema a ver si damos con la tecla.

    Escenario
    –----------
    Hotel , router microtik ip 192.168.1.1 , pfsense con
    wan: 192.168.1.2 gateway 192.168.1.1
    lan: 192.168.192.1

    Portal cautivo activado, servidor dhcp con el rango 192.168.192.50 -- 192.168.192.240 puerta de enlace 192.168.192.1 y dns 192.168.192.1

    Problema

    Portal cautivo funciona, me aparece la web y pongo usuario y contraseña.

    Clientes PC y Portatiles: funciona todo sin problemas
    Clientes Android: alguna paginas no terminan de cargar o pierden el CSS, con algunas apps como la del facebook no me cargaba las imagenes pero si los textos.

    Clintes IOS (ipad y derivados): se conecta pide la clave y al redirigir a la pagina del hotel se queda ahi, luego no navegan o si lo hacen tardan 20 minutos en tardar una web.

    repito que los ordenadores portatiles funciona perfectamente.

    Cosas que he probado:

    • crear un certificado de seguridad y hacer login por https
    • autoañadir la mac del dispositivo para que no tenga que volver a hacer login en 3 dias.
    • Desactivar en Firewall: si lo hago me deja de enrutar y no funciona la navegacion.

    estoy un poco atascado que podría revisar? he probado a modificar el agent del navegador de android

    muchas gracias de antemano

    vicente



  • Google captive portal pfsense android ios

    http://forums.appleinsider.com/t/153426/ios-6-and-captive-portals



  • Gracias eso ya lo había probado, pero creo que he dado con la tecla, a IOS no le gusta la dirección despues del login, ha sido quitarla y funcionar como la seda.


Log in to reply