OpenVPN / Cert Backup - Restore issue BUG!



  • Hello All,

    I've made a full backup of my primary pfsense using the , but when i try to restore the OpenVPN settings using the https://pfsense01/diag_backup.php utility, i get this error:

    _The following input errors were detected:

    You have selected to restore an area but we could not locate the correct xml tag._

    Is this a known issue?
    Am i doing something wrong?

    Nuno





  • Hello,

    But if i do a full restore of the xml generated by the diag_backup.php utility i still get restored to all the CA's, CRT's and openvpn configs right?

    Thanks for your help. Wonderful product.

    Nuno.



  • Yes, full backup and full restore are doing everything, including certificates, OpenVPN settings…
    It was just a bug in the code that was not matching and finding the <openvpn>section of the config that was causing it to not work when trying to do just that specific section.</openvpn>



  • I needed to restore just the OpenVPN config, so I tried making the edit to that file myself and seemed to have broken something.  I changed ovpn to openvpn like the fix suggests but now when I go to the diag_backup.php page I get

    Warning: Invalid argument supplied for foreach() in /etc/inc/util.inc on line 796 Warning: Invalid argument supplied for foreach() in /etc/inc/util.inc on line 796 Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /etc/inc/util.inc:796) in /etc/inc/auth.inc on line 1357
    
    No page assigned to this user! Click here to logout.
    

    UPDATE
    Ok, so putting it back to ovpn fixed it.  How can I apply the bug fix without breaking it?



  • You really just need to type the 3 letters "pen" in the middle of "ovpn"to make "openvpn".
    I can only guess that you have accidentally deleted or added some syntax character when making the edit.
    This change is simple enough that I would just do it from Diagnostics->Edit, Load, type the 3 chars in the right place and press "Save". No need to mess with command line.


Log in to reply