Is this a Configuration problem?



  • Hi,

    I recently upgraded from 2.0.3 to 2.1 and now I get the following line constantly repeated in my logs:

    ipfw-classifyd: unable to write to divert socket: Invalid argument
    

    From what I can tell it has something to do with he firewall and Layer 7. I was not getting this error before the upgrade, so what gives?


  • Banned

    Which configuration? You posted zero information about your configuration.



  • Here is some follow up. I disabled all layer 7 rules in the firewall and the errors have stopped. I do not know why this error is occurring since everything was working just fine in 2.0.3. Anybody have any ideas?

    Here are the screenshots of my config:



  • bump

    I'm still getting this error when I try to set any L7 filter:

    ipfw-classifyd: unable to write to divert socket: Invalid argument
    

    Any ideas? I'm at a loss.


Log in to reply