Squid & Skype



  • Hola , tengo SQUID de modo que niegue todo el trafico excepto lo que esta especificamente permitido.
    Necesitaría habilitar el skype para que funcione a través de SQUID pero las soluciones que encontré en la web con expresiones regulares, si mal no entiendo, habilitan todo el rango de direcciones publicas y no solo las de skype.

    acl skype url_regex -i ([0-9]{1,3}.){3}[0-9]{1,3}
    http_access allow skype

    Alguien tuvo este problema ? Estoy buscando habilitar desde SQUID lo minimo indispensable para que funcione skype.

    Gracias



  • Eso es incompleto, por lo que veo, porque hay que usarlo conjuntamente con la identificación del navegador. En este caso, el navegador es Skype.

    http://wiki.squid-cache.org/ConfigExamples/Chat/Skype

    Google squid skype



  • Muchas Gracias Maestro Bellera, no sabia que Squid podía identificar navegadores y mucho menos que a skype se lo consideraba como un navegador.



  • Amigo a mi me paso igual y aun abriendo los puertos no entraban los usuarios al skype de igual manera bloquie todo y deje libre los puerto necesarios para mi red en el cortafuego el caso es k el problema estaba en la blacklist k me baje en este caso estaba en el apartado de phone lo tenia denegado y dandole acceso me funciono de maravilla espero te ayude esta experiencia



  • Saludos mi estimado, usas squid transparente?? si esto no es asi ps solo debes saber en que puerto estas trabajando skype habilitarlo en squid y en el caso que no sea transparente debes configurar skype de modo manual con tu squid….. Normalmente para este tipo de configuraciones lo hago mediante configuracion de archivo proxy.pac obviamente este requiere o un server web, pero es excelente porque podrias hacer cambios en tu configuracion sin necesidad de dirigirte a la maquina del cliente cada vez. Estamos a la orden



  • Estimados

    Entiendo que esas configuraciones se ponen directo en el archivo de configuración de Squid, pero…

    ¿Donde se debería poner si usamos la interfaz Web de PFSense?



  • En Custom Options de la pestaña General, separando cada salto de línea por un punto y coma (;)



  • Gracias, presumí que era ahí y lo hice. Sin embargo sigue sin funcionar, por lo que he leído en otros sitios Skype siempre intenta conectar directo, aunque esté configurado explícitamente el proxy en su configuración.

    Ocurre que si el cliente de Skype ya se ha conectado antes y tiene su información de login guardada conecta bien a través del proxy, pero si se intenta ingresar con otra cuenta o agregar contactos insiste en conectar de forma directa. De hecho lo veo en los logs, intenta conectarse a IPs aleatorias por el puerto 443.



  • Antes que nada…recordaste configurar el proxy EN EL SKYPE?

    --

    En un squid.conf en debian, lo hice del siguiente modo. Ajustar según las necesidades! No copiar y pegar si no se está seguro de lo que se hace.

    Supongo que hay una o más ips que pueden usar skype. Lo englobo en el ejemplo dentro de "ip_permitida"

    
    acl skype src "ip_permitida"
    acl numeric_ips dstdom_regex ^(([0-9]+.[0-9]+.[0-9]+.[0-9]+)|([([0-9af]+)?:([0-9af:]+)?:([0-9af]+)?])):443
    acl skype_ua browser ^skype
    acl validuseragent browser \S+
    
    http_access deny numeric_ips !skype
    http_access deny skype_ua !skype
    http_access deny !validuseragent !skype
    

    En caso de que quieras bloquearlo para todos

    
    acl numeric_ips dstdom_regex ^(([0-9]+.[0-9]+.[0-9]+.[0-9]+)|([([0-9af]+)?:([0-9af:]+)?:([0-9af]+)?])):443
    acl skype_ua browser ^skype
    acl validuseragent browser \S+
    
    http_access deny numeric_ips all
    http_access deny skype_ua all
    http_access deny !validuseragent all
    

    Cuidado, puede llegar a bloquear todos las ips en puerto 443

    Saludos!!


Log in to reply