No me reconoce lan-usb



  • saludos amigo

    estoy tratando de instalar pfsense2.1 pero no reconoce una tarjeta lan-usb, se puede instalar los driver de linux para que me la reconosca, porque la tarjeta si trae los driver linux, si hay, alguien sugierame un manual para instalarlo :)


  • Rebel Alliance

    No, no puedes "instalar" los drivers de Linux… pfSense está basado en FreeBSD, por lo tanto necesitas "Drivers" para FreeBSD ;)

    Aquí tienes la lista de HW soportado por FreeBSD 8.3, en el que se basa pfSense 2.1

    https://www.freebsd.org/releases/8.3R/hardware.html



  • que mal
    gracias por tu respuesta
    los desarrolladores de  freebsd o pfsense deberían crear o incorporar mas soportes (driver)para dispositivos USB_LAN modernas, el problema mio es que tengo un mainboard sin ranuras pci para poner una lan-pci


  • Rebel Alliance

    Que Motherboard tienes ?

    Que marca/modelo de adaptador USB tienes ?

    Cuando conectas el adaptador USB, que aparece en la consola del pfSense, detecta que se conectó algo al USB ?



  • solo me reconoce un adaptador re0 por la forma que lo reconoce es realtec entonces se que es el que trae incorporado la placa base

    y si cuando desconecto me sale ugen4.2 moschip semiconductor
    pero cuando pongo asignar interfaces me sale solo la re0


  • Rebel Alliance

    No comentas que Motherboard tienes (Marca/Modelo), no tiene Slots PCI-E ?

    Debes identificar el Chip, del adaptador USB, en concreto y luego buscas en el foro….

    https://forum.pfsense.org/index.php?topic=39550.msg203815#msg203815

    https://forum.pfsense.org/index.php?topic=50241.0

    https://forum.pfsense.org/index.php?topic=66604.0



  • el modelo no lo tengo a la mano no lo tiene impreso pero se que es intel lo podria ver es con un software bajo windows pero son los mini-mainboard en los que vienen incorporado el procesador en la placa  una sola ranura ram ddr2 y un pci-express, te comento que quise montar un pendrive usb pero no lo puedo montar no me aparece como sda0s1 solo me sale ugen4.3 y al montarlo me dice que es requerido el block y no se como proseguir


  • Rebel Alliance

    Si tiene PCI-E, por que no utilizas un adaptador de red PCI-E en lugar del USB ?



  • el asunto es porque hace dos días me robaron en mi local y se me llevaron todos mis equipos y estoy de nuevo montando con lo que tengo ala mano además he quedado desfinanciado  :'( :'(


  • Rebel Alliance

    Que mal  :(

    Pero de todas formas un adaptador de red PCI-E de los económicos como el TP-Link TG-3468 anda por los 8 ~ 10 dólares y estoy seguro que funcionará mejor que uno USB ;)

    Lamento no poder ser de mas ayuda :( espero puedas solucionar tu problema.



  • tranquilo amigo no se preocupe

    pero hasta que me salga el préstamo tengo que solucionar con lo que tengo porque también doy asistencia remota a varios clientes ojala pueda instalar con el usb-lan y ya tengo dos días offline



  • saludo amigo "ppt"

    estoy haciendo esto:

    mkdir /mnt/stick
    mount_msdosfs /dev/da0s1 /mnt/stick
    cp /mnt/stick/if_mos.ko /boot/kernel
    kldload if_mos.ko
    vi /boot/loader.conf
    i

    Add in:
    if_mos_load="YES"
    to the end of the file.
    Hit Esc.  Type :w and hit enter, then type :q and hit enter.
    quit
    And then reboot the system.

    he tenido problemas con los comandos "vi" no puedo ingresar el texto algun manual de como usar usar esos comandos





  • saludos bellera

    esta muy interesante el enlace que me enviaste segun lo que pude traducir al vuelo es que se utiliza el comando kldload para compilar driver para pfsense voy a ponerlo en practica despues de traducirlo bien

    gracias por tu apoyo

    igual utilice unos de los enlaces del usuario "ppt" donde ya habia un driver compilado e hice todos los pasos ,los de los comandos vi por shell lo soluciones aunque adivinando y pensando como 5 horas pero lo logre, y aprendi ,despues de tan maratonica matada de cerebro pense y porque no entre al sistema y modifique el archivo con un editor de texto,  ;D ;D ;D ;D ;D debi estar bruto en ese momento, pero bueno igual aprendi

    ahora tengo un inconveniente aveces cuando arranco el pfsense no me detecta el usb wan como conectado al cable de internet y me sale que "ue0" esta "down" el cual me dice si quiero crear "vlan" y ahi se queda y no avanza entonces tengo que reiniciar el pfsense y ahi lo reconoce bien ,aunque estoy pensando que sea problema del driver pero no estoy seguro, me tocara aplicar tu manual y crear el driver con kldload

    otro asunto es que me quedo el foco indicador de trafico del usb-lan intermitente pensaba que era trafico pero desconecte la red lan de la pc pero igual sigue pero no es siguido intermitea 3 veces y se queda quieto 3segundo y vuelve de de nuevo no se a que deba


Log in to reply