Error Cliente FTP detras del Pfsense 2.1



  • Hola, que tal?
    Quería comunicarme con ustedes para ver si me pueden ayudar a resolver el siguiente inconveniente.
    Acabo de instala el Pfsense 2.1, importe las opciones de mi versión anterior, corregí lo que estaba mal importado, y a partir de ese momento solo tengo un error por ahora.
    Cuando me quiero conectar desde afuera de mi LAN a la misma donde tengo un servidor FTP (Pure-FTP) sobre un debian 7, me genera el siguiente error tanto en modo pasivo como activo con el FileZilla:
    MODO ACTIVO

    Estado: Resolviendo la dirección de ftp.xxx.com.ar
    Estado: Conectando a xxx.xxx.xxx.xxx:21
    Estado: Conexión establecida, esperando el mensaje de bienvenida...
    Respuesta: 220---------- Welcome to Pure-FTPd [privsep] [TLS] –--------
    Respuesta: 220-You are user number 1 of 50 allowed.
    Respuesta: 220-Local time is now 21:24. Server port: 21.
    Respuesta: 220-This is a private system - No anonymous login
    Respuesta: 220-IPv6 connections are also welcome on this server.
    Respuesta: 220 You will be disconnected after 15 minutes of inactivity.
    Comando: USER xxx
    Respuesta: 331 User xxx OK. Password required
    Comando: PASS ********
    Respuesta: 230 OK. Current restricted directory is /
    Comando: SYST
    Respuesta: 215 UNIX Type: L8
    Comando: FEAT
    Respuesta: 211-Extensions supported:
    Respuesta: EPRT
    Respuesta: IDLE
    Respuesta: MDTM
    Respuesta: SIZE
    Respuesta: MFMT
    Respuesta: REST STREAM
    Respuesta: MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
    Respuesta: MLSD
    Respuesta: AUTH TLS
    Respuesta: PBSZ
    Respuesta: PROT
    Respuesta: UTF8
    Respuesta: ESTA
    Respuesta: PASV
    Respuesta: EPSV
    Respuesta: SPSV
    Respuesta: ESTP
    Respuesta: 211 End.
    Comando: OPTS UTF8 ON
    Respuesta: 200 OK, UTF-8 enabled
    Estado: Conectado
    Estado: Recuperando el listado del directorio...
    Comando: PWD
    Respuesta: 257 "/" is your current location
    Comando: TYPE I
    Respuesta: 200 TYPE is now 8-bit binary
    Comando: PORT 192,168,24,104,198,240
    Respuesta: 200 PORT command successful
    Comando: MLSD
    Error: Conexión superó el tiempo de espera
    Error: Error al recuperar el listado del directorio

    MODO PASIVO

    Estado: Resolviendo la dirección de ftp.xxx.com.ar
    Estado: Conectando a xxx.xxx.xxx.xxx:21
    Estado: Conexión establecida, esperando el mensaje de bienvenida...
    Respuesta: 220---------- Welcome to Pure-FTPd [privsep] [TLS] –--------
    Respuesta: 220-You are user number 1 of 50 allowed.
    Respuesta: 220-Local time is now 21:44. Server port: 21.
    Respuesta: 220-This is a private system - No anonymous login
    Respuesta: 220-IPv6 connections are also welcome on this server.
    Respuesta: 220 You will be disconnected after 15 minutes of inactivity.
    Comando: USER xxx
    Respuesta: 331 User xxx OK. Password required
    Comando: PASS ********
    Respuesta: 230 OK. Current restricted directory is /
    Comando: OPTS UTF8 ON
    Respuesta: 200 OK, UTF-8 enabled
    Estado: Conectado
    Estado: Recuperando el listado del directorio...
    Comando: PWD
    Respuesta: 257 "/" is your current location
    Comando: TYPE I
    Respuesta: 200 TYPE is now 8-bit binary
    Comando: PASV
    Error: Conexión superó el tiempo de espera
    Error: Error al recuperar el listado del directorio

    Tengo el firewall en el servidor Debian activo, y con los puertos 20 y 21 abiertos.
    También, verifiqué que dichos puertos estén redirigidos (NAT), en la otra pc con el Pfsense, hacia la IP del servidor en la LAN con sus respectivas reglas de permiso en la sección de firewall.

    En todos los lugares que probé conectarme, no lo conseguí, incluso diferentes clientes FTP y nada hasta que un dia probe desde una MAC, con el transmit FTP en modo activo y se pudo unicamente.

    Antes de actualizar el pfsense no me sucedia. Sustitui el mismo por un router 3com configurado, y anduvo sin problemas desde cualquier lugar. La conexion WAN es de varias IPs fijas publicas, y tambien estan configuradas con sus respectivos gateways en el pfsense, aun asi nada. En la parte de NAT outbound puse manual y automatico, y nada.
    Cuando trate de conectarme de la casa de un amigo, el tambien tenia un router de por medio, lo quitamos, y nada!

    Que puede ser lo que genera el conflicto?

    Gracias




  • https://forum.pfsense.org/index.php?topic=65882.0  –-> Dicen que funciona

    https://forum.pfsense.org/index.php?topic=58678.0 ---> Dicen que no les va

    Google ftp server port forward site:forum.pfsense.org

    Si puedes, múdate a SFTP (FTP sobre SSH) con http://mysecureshell.sourceforge.net (shell para poder hacer sólo SCP y SFTP).

    Un único puerto y comunicación segura. El problema es que si es un servidor público tendrás que dar un usuario/clave.

    https://doc.pfsense.org/index.php/FTP_Troubleshooting (obsoleto, en su mayoría)

    Oh no, the above doesn't help. What can I do?

    Use SCP/SFTP which only needs 1 port to traverse the firewall since its wrapped in SSH (yes a safe AND simple way of traversing a firewall!)
        Don't use FTP



  • Saludos mi estimado, como indica mi estimado maestro bellera sobre ssh funcionaria perfecto. Actualmente lo uso para varias redes de servicios que tengo y funciona excelente es cosa de crear solamente los nat en pfsense necesarios. Estamos a la orden


Log in to reply