Problema OpenVPN. El cliente entra pero no veo la LAN



  • Hola

    Soy muy nuevo en esto de los firewalls y me haria falta algo de ayuda.
    Estoy haciendo pruebas para conectar por VPN y googleando he llegado al gran howto de Josep de Bellera. Lo he configurado como pone allí y me conecta el cliente OpenVPN GUI, pero no tengo conexion a un PC con windows que esta en la LAN.
    La unica regla que tengo en el firewall es abrir el puerto tcp 1194 para acceder via OpenVPN. Supongo qaria falta introducir mas reglas para que se vieran un PC de la LAN con uno de la VPN y viceversa.

    Alguien me dice por donde puedo tirar?

    Gracias

    Ivan



  • ¡Hola!

    En principio un cliente que ha entrado por VPN tiene que ver la LAN, si lo has configurado como dice en el tutorial.

    Podría ser que tuvieses alguna regla en la LAN que te esté bloqueando el tráfico. En todo caso prueba a poner una regla que autorice todo lo que venga de la IP de tu cliente VPN y así podrás ver si es esto.

    Otra posibilidad es que tus máquinas, tanto el cliente VPN como la máquina de la LAN tengan un cortafuegos instalado. Si son Windows XP será seguramente así. Y por defecto el cortafuegos de Windows tiene activada la compartición de archivos sólo para la subred. Prueba a desactivar los cortafuegos en las máquinas, a ver si es esto. Si es esto, vuelve a activarlos y entra en las excepciones para cambiar los tramos de red de la compartición de archivos …

    Saludos,

    Josep Pujadas



  • Hola

    No tengo ningún firewall en los windowsXP, es lo primero que he comprobado, y lo de las reglas lo acabo de probar y tampoco me deja acceder. He creado una regla en la LAN con acceso total desde TCP/UDP, y sigo sin tener ping de una maquina a otra. Seguiré probando y repasando tu tutorial.

    Es posible que las "Custom Options" no esten correctas??
    push "route 192.168.1.0 255.255.255.0";push "route 192.168.10.0/24"
    Siendo 192.168.1.0 mi LAN y 192.168.10.0 mi VPN

    Gracias por la rapida respuesta

    Salutacions

    Ivan



  • @banksy:

    Hola

    Soy muy nuevo en esto de los firewalls y me haria falta algo de ayuda.
    Estoy haciendo pruebas para conectar por VPN y googleando he llegado al gran howto de Josep de Bellera. Lo he configurado como pone allí y me conecta el cliente OpenVPN GUI, pero no tengo conexion a un PC con windows que esta en la LAN.
    La unica regla que tengo en el firewall es abrir el puerto tcp 1194 para acceder via OpenVPN. Supongo qaria falta introducir mas reglas para que se vieran un PC de la LAN con uno de la VPN y viceversa.

    Alguien me dice por donde puedo tirar?

    ¿Te está bloqueando el firewall el tráfico desde el interfaz TUN0?

    Si es así, el problema está en que no se han cargado bien las reglas para permitir el acceso de los clientes de VPN a través del túnel.

    Busca en el log una orden línea que dirá: /etc/rc.filter_configure tun0 …....... (los puntos suspensivos dependerán de tu configuración) y ejecuta esa orden en tun pfSense.



  • Es posible que las "Custom Options" no esten correctas??
    push "route 192.168.1.0 255.255.255.0";push "route 192.168.10.0/24"
    Siendo 192.168.1.0 mi LAN y 192.168.10.0 mi VPN

    Esto no es correcto. El push de route sólo debe ponerse para las LANs que no sean la LAN (la LAN hay que meterla donde pone Local network), tal como está en el tutorial. Y jamás para la VPN; estás confundiendo a tu cliente VPN.

    En el tutorial, http://www.bellera.cat/josep/pfsense/openvpn_cs.html#server los rangos son:

    192.168.XXX.0/24 para la LAN
    192.168.YYY.0/24 para Alumnos (otra LAN)
    192.168.ZZZ.0/24 para Wireless (otra LAN)

    Fíjate que sólo se hace push para los tramos YYY y ZZZ …

    El tutorial podría ser más simple, pero está basado en un caso real. Tienes el esquema en:

    http://www.bellera.cat/josep/pfsense/cas_estudi_cs.html#objectius

    En resumen, en tu caso puedes pasar de las Custom options

    Te sugiero reinicies el cortafuegos después de los cambios. Supongo que estará arreglado pero en versiones antiguas de pfSense había que hacer un arranque limpio de pfSense para que OpenVPN se pusiera a tono.

    Saludos,

    Josep Pujadas



  • Tal como dices, he dejado en blanco las Custom Options, he reiniciado y funciona!

    Muchas gracias por vuestra ayuda


Log in to reply