Squid3 y squidguard



  • Hola:
    Antes de nada volved a disculpar mi torpeza pero estoy intentando aprender y mis conocimientos son bastante básicos. Así que gracias a todos por anticipado.

    Tenia instalado Squid 2 con Squidguard funcionando bien.

    Intenté pasar a Squid3 y Squidguard con el manual del señor bellera

    https://forum.pfsense.org/index.php?topic=73740.0

    Aparentemente lo hice todo bien pero no me filtraba nada ni conseguida que hiciera nada.

    Y ahora empieza mi berenjenal.

    Desinstalé los paquete para volver como estaba antes pero Squid 2 ya no me aparece.

    Cuando reinstalo los paquete me sale la configuracion  que tenia antes. No puedo borrar todo resto de Squid y Squidguard?
    Cuando instalas el Squid 3, hace falta instalar el 2? o Squid antes? O puedes instalar Squid3 y squidguard3 directamente?

    Ahora no arranca el Squid. Parte del  log es:

    Last 50 system log entries
    Apr 4 11:51:47 php: rc.filter_configure_sync: SQUID is installed but not started. Not installing "filter" rules.
    Apr 4 11:51:47 php: rc.filter_configure_sync: SQUID is installed but not started. Not installing "pfearly" rules.
    Apr 4 11:51:47 php: rc.filter_configure_sync: SQUID is installed but not started. Not installing "nat" rules.
    Apr 4 11:51:45 check_reload_status: Reloading filter
    Apr 4 11:51:35 php: /pkg_edit.php: The command '/usr/pbi/squid-i386/sbin/squid -f /usr/pbi/squid-i386/etc/squid/squid.conf' returned exit code '1', the output was '2014/04/04 11:51:35| ERROR: redirect_program /usr/pbi/squidguard-i386/bin/squidGuard: (2) No such file or directory FATAL: redirect_program /usr/pbi/squidguard-i386/bin/squidGuard: (2) No such file or directory Squid Cache (Version 3.1.22): Terminated abnormally. CPU Usage: 0.007 seconds = 0.000 user + 0.007 sys Maximum Resident Size: 4900 KB Page faults with physical i/o: 0'
    Apr 4 11:51:35 squid: redirect_program /usr/pbi/squidguard-i386/bin/squidGuard: (2) No such file or directory
    Apr 4 11:51:35 php: /pkg_edit.php: Starting Squid
    Apr 4 11:51:34 check_reload_status: Syncing firewall
    Apr 4 11:51:18 php: rc.filter_configure_sync: SQUID is installed but not started. Not installing "filter" rules.
    Apr 4 11:51:18 php: rc.filter_configure_sync: SQUID is installed but not started. Not installing "pfearly" rules.
    Apr 4 11:51:18 php: rc.filter_configure_sync: SQUID is installed but not started. Not installing "nat" rules.
    Apr 4 11:51:18 lighttpd[21443]: (connections.c.137) (warning) close: 14 Connection reset by peer
    Apr 4 11:51:16 check_reload_status: Reloading filter
    Apr 4 11:51:08 php: rc.filter_configure_sync: SQUID is installed but not started. Not installing "filter" rules.
    Apr 4 11:51:07 php: rc.filter_configure_sync: SQUID is installed but not started. Not installing "pfearly" rules.
    Apr 4 11:51:07 php: rc.filter_configure_sync: SQUID is installed but not started. Not installing "nat" rules.
    Apr 4 11:51:07 php: rc.filter_configure_sync: SQUID is installed but not started. Not installing "filter" rules.
    Apr 4 11:51:07 php: rc.filter_configure_sync: SQUID is installed but not started. Not installing "pfearly" rules.
    Apr 4 11:51:07 php: rc.filter_configure_sync: SQUID is installed but not started. Not installing "nat" rules.
    Apr 4 11:51:06 php: /pkg_edit.php: The command '/usr/pbi/squid-i386/sbin/squid -f /usr/pbi/squid-i386/etc/squid/squid.conf' returned exit code '1', the output was '2014/04/04 11:51:06| ERROR: redirect_program /usr/pbi/squidguard-i386/bin/squidGuard: (2) No such file or directory FATAL: redirect_program /usr/pbi/squidguard-i386/bin/squidGuard: (2) No such file or directory Squid Cache (Version 3.1.22): Terminated abnormally. CPU Usage: 0.007 seconds = 0.000 user + 0.007 sys Maximum Resident Size: 34952 KB Page faults with physical i/o: 0'

    Alguien puede iluminarme u orientarme un poco?

    He leído todo lo que he podido pero hay demasiadas  cosas que se me escapan.

    Gracias por todo.
    Un saludo.



  • Modifiqué tu post en cuanto a nomenclatura de squidGuard.

    ¡Ojo con la nomenclatura! Podemos crear confusiones…

    squid3-dev 3.3.10 pkg 2.2.1
    Binario squid 3.3.10 http://www.freebsd.org/cgi/ports.cgi?query=squid3
    Configurador 2.2.1

    squidGuard-squid3 1.4_4 pkg v.1.9.5
    Binario squidGuard 1.4_4 http://www.freebsd.org/cgi/ports.cgi?query=squidGuard
    Configurador v.1.9.5

    http://www.freebsd.org/cgi/ports.cgi?query=squid-2

    En conclusión squidGuard no va más allá de su versión 1.4. Lo que cambia es la integración en squid2 o squid3, que tiene distinta sintaxis.



  • /usr/pbi/squidguard-i386/bin/squidGuard: (2) No such file or directory FATAL
    

    No arranca porque no encuentra a squidGuard.



  • Hola,

    yo tenia instalado 2.1 con squid, squid3 (tengo los dos squid y no hay conflico pero fue la unica manera de funcionar) y squidguard, tuve los mismo problemas, despues de tanto webiar instale unos paquetes nuevos.

    fetch -o /usr/local/lib/libasn1.so.10 http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ldd/libasn1.so.10
    fetch -o /usr/local/lib/libgssapi.so.10 http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ldd/libgssapi.so.10
    fetch -o /usr/local/lib/libheimntlm.so.10 http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ldd/libheimntlm.so.10
    fetch -o /usr/local/lib/libhx509.so.10 http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ldd/libhx509.so.10
    fetch -o /usr/local/lib/libkrb5.so.10 http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ldd/libkrb5.so.10
    fetch -o /usr/local/lib/libroken.so.10 http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ldd/libroken.so.10

    reinicie el pfsense y hoy 4-abril me pidie actualizcion yo actualice a la 2.1.1-RELEASE y SOLO se soluciono el problema, teniendo en funcionamiento squid y squidguard.

    saludos.



  • Gracias a ambos.

    Instalo los paquetes de squid e squidguard y no me da ningún error.
    Esta mañana he actualizado a la 2.1.1 pero de momento nada.
    Sigo en ello. :D

    Gracias



  • Hola:
    Mis conocimientos no dan para mas. Voy a deinstalar todos los paquetes y empezar de cero.

    Una vez desinstalados tengo que borrar algo para que si lo vuelvos a instalar no quede ninguna configuración?

    Sino lo reinstalaré todo de nuevo (pfsense formateando).  Vosotros instalariais después  squid, squid3-dev y squidGuard-devel?

    Tenia configurado el ntop y el lightsquid. Es conveniente que lo desinstale también,no?

    Gracias de nuevo por todo.



  • Una vez desinstalados tengo que borrar algo para que si lo vuelvos a instalar no quede ninguna configuración?

    Deberías mirar que no queden restos de la configuración de squid o de squidGuard en config.xml

    Es donde está todo.

    Vosotros instalariais después  squid, squid3-dev y squidGuard-devel?

    Sólo un squid y sólo un squidGuard.

    Por ejemplo squid3-dev + squidGuard-squid3. Los pasos para squid3-dev + squidGuard-squid3 están detallados en Documentación y en Últimas aportaciones a Documentación de este foro.

    Algunos usuarios están diciendo que al pasar de 2.1 a 2.1.1 les dejó de funcionar SSL Bump. Igual es porque hay un cambio en OpenSSL que les afecta, relativo a que los países sólo tienen dos letras. Es un tema muy específico.

    ¡Suerte y paciencia!

    Y si no lo ves claro, todo desde cero. Montar un pfSense desde cero no suele ser una tarea muy larga.





  • Gracias una vez más.

    Ya he borrado cualquier rastro de  squid3 y  squidGuard en config.xml.

    He reinstalado  squid3-dev + squidGuard-squid3 y  lo ha hecho correctamente .

    Ahora voy a configurarlo todo de nuevo y a ver….

    Tengo esa versión de squid3 y la versión 2.1.1 de pfsense pero de momento continuo...



  • Hola:
    Pues de momento ya lo tengo funcionando. Sólo en http pero https lo intentaré en los próximos días.

    Limpié el archivo config.xml, las caches y cualquier resto que encontré de squid , reinstalé y volvió a iniciar y filtrar todo.

    Gracias a todos por vuestra ayuda.

    Gracias y un saludo.


Log in to reply